<!doctype html > <!--[if IE 8]><html class="ie8" lang="en"> <![endif]--> <!--[if IE 9]><html class="ie9" lang="en"> <![endif]--> <!--[if gt IE 8]><!--><html lang="en-CA"> <!--<![endif]--><head><!-- <link media="all" href="https://www.geeskaafrika.com/wp-content/cache/autoptimize/css/autoptimize_0ba2ad55983f6ed7aab5a5ec3bd98c70.css" rel="stylesheet" /> -->
<link rel="stylesheet" type="text/css" href="//www.geeskaafrika.com/wp-content/cache/wpfc-minified/9l8f2n50/7psyp.css" media="all"/><style media="screen">.page-template p,.category p{display:none !important}</style><title>Somaliland to Join British Commonwealth Again:1954</title><meta charset="UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1.0"><link rel="pingback" href="https://www.geeskaafrika.com/xmlrpc.php" /><meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' /><meta property="og:image" content="https://www.geeskaafrika.com/wp-content/uploads/2022/01/egal_1954.jpg" /><meta name="description" content="London (HAN) 17 January 2022 - Diplomacy and Regional Security Issues for The latest news and announcements including. President of Rwanda, and" /><link rel="canonical" href="https://www.geeskaafrika.com/somaliland-to-join-british-commonwealth-again1954/" /><meta name="twitter:card" content="summary" /><meta name="twitter:title" content="Somaliland to Join British Commonwealth Again:1954" /><meta name="twitter:description" content="London (HAN) 17 January 2022 - Diplomacy and Regional Security Issues for The latest news and announcements including. President of Rwanda, and" /><meta name="twitter:image" content="https://www.geeskaafrika.com/wp-content/uploads/2022/01/egal_1954.jpg" /><meta name="twitter:creator" content="@GeskaAfrika" /><meta name="twitter:site" content="@GeskaAfrika" /><meta name="twitter:label1" content="Written by" /><meta name="twitter:data1" content="geeskaadmin" /><meta name="twitter:label2" content="Est. reading time" /><meta name="twitter:data2" content="2 minutes" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.geeskaafrika.com/#organization","name":"Geeska Afrika Online","url":"https://www.geeskaafrika.com/","sameAs":["https://www.facebook.com/GeeskaAfrikaOnline","https://twitter.com/GeskaAfrika"],"logo":{"@type":"ImageObject","@id":"https://www.geeskaafrika.com/#logo","inLanguage":"en-CA","url":"https://www.geeskaafrika.com/wp-content/uploads/2020/09/21518_1073054759412503_2480503412749858202_n.png","contentUrl":"https://www.geeskaafrika.com/wp-content/uploads/2020/09/21518_1073054759412503_2480503412749858202_n.png","width":600,"height":400,"caption":"Geeska Afrika Online"},"image":{"@id":"https://www.geeskaafrika.com/#logo"}},{"@type":"WebSite","@id":"https://www.geeskaafrika.com/#website","url":"https://www.geeskaafrika.com/","name":"Geeska Afrika Online 1985-2022","description":"Daily Horn of Africa News Line (HAN)","publisher":{"@id":"https://www.geeskaafrika.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.geeskaafrika.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-CA"},{"@type":"ImageObject","@id":"https://www.geeskaafrika.com/somaliland-to-join-british-commonwealth-again1954/#primaryimage","inLanguage":"en-CA","url":"https://www.geeskaafrika.com/wp-content/uploads/2022/01/egal_1954.jpg","contentUrl":"https://www.geeskaafrika.com/wp-content/uploads/2022/01/egal_1954.jpg","width":720,"height":578},{"@type":"WebPage","@id":"https://www.geeskaafrika.com/somaliland-to-join-british-commonwealth-again1954/#webpage","url":"https://www.geeskaafrika.com/somaliland-to-join-british-commonwealth-again1954/","name":"Somaliland to Join British Commonwealth Again:1954","isPartOf":{"@id":"https://www.geeskaafrika.com/#website"},"primaryImageOfPage":{"@id":"https://www.geeskaafrika.com/somaliland-to-join-british-commonwealth-again1954/#primaryimage"},"datePublished":"2022-01-17T09:37:06+00:00","dateModified":"2022-01-17T10:16:17+00:00","description":"London (HAN) 17 January 2022 - Diplomacy and Regional Security Issues for The latest news and announcements including.\u00a0President of Rwanda, and","breadcrumb":{"@id":"https://www.geeskaafrika.com/somaliland-to-join-british-commonwealth-again1954/#breadcrumb"},"inLanguage":"en-CA","potentialAction":[{"@type":"ReadAction","target":["https://www.geeskaafrika.com/somaliland-to-join-british-commonwealth-again1954/"]}]},{"@type":"BreadcrumbList","@id":"https://www.geeskaafrika.com/somaliland-to-join-british-commonwealth-again1954/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.geeskaafrika.com/"},{"@type":"ListItem","position":2,"name":"Somaliland to Join British Commonwealth Again:1954"}]},{"@type":"NewsArticle","@id":"https://www.geeskaafrika.com/somaliland-to-join-british-commonwealth-again1954/#article","isPartOf":{"@id":"https://www.geeskaafrika.com/somaliland-to-join-british-commonwealth-again1954/#webpage"},"author":{"@id":"https://www.geeskaafrika.com/#/schema/person/60f08a5a43b6380624f0ed54e24f09ac"},"headline":"Somaliland to Join British Commonwealth Again:1954","datePublished":"2022-01-17T09:37:06+00:00","dateModified":"2022-01-17T10:16:17+00:00","mainEntityOfPage":{"@id":"https://www.geeskaafrika.com/somaliland-to-join-british-commonwealth-again1954/#webpage"},"wordCount":243,"commentCount":0,"publisher":{"@id":"https://www.geeskaafrika.com/#organization"},"image":{"@id":"https://www.geeskaafrika.com/somaliland-to-join-british-commonwealth-again1954/#primaryimage"},"thumbnailUrl":"https://www.geeskaafrika.com/wp-content/uploads/2022/01/egal_1954.jpg","articleSection":["Ethiopia","Events","frontpage","Latest News","Press Release","Somalia","Somaliland","World News"],"inLanguage":"en-CA","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://www.geeskaafrika.com/somaliland-to-join-british-commonwealth-again1954/#respond"]}]},{"@type":"Person","@id":"https://www.geeskaafrika.com/#/schema/person/60f08a5a43b6380624f0ed54e24f09ac","name":"geeskaadmin"}]}</script> <link rel="amphtml" href="https://www.geeskaafrika.com/somaliland-to-join-british-commonwealth-again1954/amp/" /><meta name="generator" content="AMP for WP 1.0.77.34"/><link rel="alternate" type="application/rss+xml" title="Geeska Afrika Online 1985-2022 &raquo; Feed" href="https://www.geeskaafrika.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Geeska Afrika Online 1985-2022 &raquo; Comments Feed" href="https://www.geeskaafrika.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Geeska Afrika Online 1985-2022 &raquo; Somaliland to Join British Commonwealth Again:1954 Comments Feed" href="https://www.geeskaafrika.com/somaliland-to-join-british-commonwealth-again1954/feed/" /> <script>(function (basket) {basket.require({ url: "https://www.geeskaafrika.com/wp-includes/js/jquery/jquery.min.js", key: "jquery-core"});})(basket);</script><script>(function (basket) {basket.require({ url: "https://www.geeskaafrika.com/wp-includes/js/jquery/jquery-migrate.min.js", key: "jquery-migrate"});})(basket);</script><script>(function (basket) {basket.require({ url: "https://www.geeskaafrika.com/wp-content/plugins/pc-google-analytics/assets/js/frontend.min.js", key: "pc_google_analytics-frontend"});})(basket);</script><link rel="https://api.w.org/" href="https://www.geeskaafrika.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.geeskaafrika.com/wp-json/wp/v2/posts/33919" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.geeskaafrika.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.geeskaafrika.com/wp-includes/wlwmanifest.xml" /><link rel='shortlink' href='https://www.geeskaafrika.com/?p=33919' /><link rel="alternate" type="application/json+oembed" href="https://www.geeskaafrika.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.geeskaafrika.com%2Fsomaliland-to-join-british-commonwealth-again1954%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.geeskaafrika.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.geeskaafrika.com%2Fsomaliland-to-join-british-commonwealth-again1954%2F&#038;format=xml" />  <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
ga('create', 'UA-48762330-1', 'auto');
ga('send', 'pageview');</script> <meta name="google-site-verification" content="YAsrjrVJIU53OpoBVG9DHFFKnqwrpXTIyLuNvHZCsQ0" /> <script>window.tdwGlobal = {"adminUrl":"https:\/\/www.geeskaafrika.com\/wp-admin\/","wpRestNonce":"4042df9d30","wpRestUrl":"https:\/\/www.geeskaafrika.com\/wp-json\/","permalinkStructure":"\/%postname%\/"};</script> <!--[if lt IE 9]><script src="https://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]--> <script>if(screen.width<769){
window.location = "https://www.geeskaafrika.com/somaliland-to-join-british-commonwealth-again1954/amp/";
}</script>  <script>var tdBlocksArray = []; //here we store all the items for the current page
//td_block class - each ajax block uses a object of this class for requests
function tdBlock() {
this.id = '';
this.block_type = 1; //block type id (1-234 etc)
this.atts = '';
this.td_column_number = '';
this.td_current_page = 1; //
this.post_count = 0; //from wp
this.found_posts = 0; //from wp
this.max_num_pages = 0; //from wp
this.td_filter_value = ''; //current live filter value
this.is_ajax_running = false;
this.td_user_action = ''; // load more or infinite loader (used by the animation)
this.header_color = '';
this.ajax_pagination_infinite_stop = ''; //show load more at page x
}
// td_js_generator - mini detector
(function(){
var htmlTag = document.getElementsByTagName("html")[0];
if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
htmlTag.className += ' ie10';
}
if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
htmlTag.className += ' ie11';
}
if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
htmlTag.className += ' td-md-is-ios';
}
var user_agent = navigator.userAgent.toLowerCase();
if ( user_agent.indexOf("android") > -1 ) {
htmlTag.className += ' td-md-is-android';
}
if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
htmlTag.className += ' td-md-is-os-x';
}
if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
htmlTag.className += ' td-md-is-chrome';
}
if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
htmlTag.className += ' td-md-is-firefox';
}
if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
htmlTag.className += ' td-md-is-safari';
}
if( -1 !== navigator.userAgent.indexOf('IEMobile') ){
htmlTag.className += ' td-md-is-iemobile';
}
})();
var tdLocalCache = {};
( function () {
"use strict";
tdLocalCache = {
data: {},
remove: function (resource_id) {
delete tdLocalCache.data[resource_id];
},
exist: function (resource_id) {
return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
},
get: function (resource_id) {
return tdLocalCache.data[resource_id];
},
set: function (resource_id, cachedData) {
tdLocalCache.remove(resource_id);
tdLocalCache.data[resource_id] = cachedData;
}
};
})();
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_ajax_url="https:\/\/www.geeskaafrika.com\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=8.1.1";
var td_get_template_directory_uri="https:\/\/www.geeskaafrika.com\/wp-content\/themes\/Newspaper";
var tds_snap_menu="smart_snap_always";
var tds_logo_on_sticky="show";
var tds_header_style="10";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#4db2ec";
var tds_smart_sidebar="enabled";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var td_ad_background_click_link="";
var td_ad_background_click_target="";</script>  <script type="application/ld+json">{
"@context": "http://schema.org",
"@type": "BreadcrumbList",
"itemListElement": [{
"@type": "ListItem",
"position": 1,
"item": {
"@type": "WebSite",
"@id": "https://www.geeskaafrika.com/",
"name": "Home"                                               
}
},{
"@type": "ListItem",
"position": 2,
"item": {
"@type": "WebPage",
"@id": "https://www.geeskaafrika.com/category/ethiopia-news/",
"name": "Ethiopia"
}
},{
"@type": "ListItem",
"position": 3,
"item": {
"@type": "WebPage",
"@id": "https://www.geeskaafrika.com/somaliland-to-join-british-commonwealth-again1954/",
"name": "Somaliland to Join British Commonwealth Again:1954"                                
}
}    ]
}</script> <meta name="google-site-verification" content="YAsrjrVJIU53OpoBVG9DHFFKnqwrpXTIyLuNvHZCsQ0" /></head><body data-rsssl=1 class="post-template-default single single-post postid-33919 single-format-standard somaliland-to-join-british-commonwealth-again1954 global-block-template-1 single_template_3 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage"><div class="td-scroll-up"><i class="td-icon-menu-up"></i></div><div class="td-menu-background"></div><div id="td-mobile-nav"><div class="td-mobile-container"><div class="td-menu-socials-wrap"><div class="td-menu-socials"> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.facebook.com/GeeskaAfrikaOnline" title="Facebook"> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://twitter.com/GeskaAfrika" title="Twitter"> <i class="td-icon-font td-icon-twitter"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="#" title="Vimeo"> <i class="td-icon-font td-icon-vimeo"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="#" title="VKontakte"> <i class="td-icon-font td-icon-vk"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="#" title="Youtube"> <i class="td-icon-font td-icon-youtube"></i> </a> </span></div><div class="td-mobile-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div></div><div class="td-mobile-content"><div class="menu-main-menu-container"><ul id="menu-main-menu" class="td-mobile-main-menu"><li id="menu-item-4059" class="home menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first menu-item-4059"><a href="https://www.geeskaafrika.com">Home</a></li><li id="menu-item-14615" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-14615"><a href="https://www.geeskaafrika.com/category/ethiopia-news/">Ethiopia</a></li><li id="menu-item-14617" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14617"><a href="https://www.geeskaafrika.com/category/eritrea-news/">Eritrea</a></li><li id="menu-item-14616" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-14616"><a href="https://www.geeskaafrika.com/category/somalia/">Somalia</a></li><li id="menu-item-14619" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14619"><a href="https://www.geeskaafrika.com/category/sudan/">Sudan</a></li><li id="menu-item-15129" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15129"><a href="https://www.geeskaafrika.com/category/djibouti-news/">Djibouti</a></li><li id="menu-item-14621" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14621"><a href="https://www.geeskaafrika.com/category/uganda/">Uganda</a></li><li id="menu-item-14283" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14283"><a href="https://www.geeskaafrika.com/category/markets/">Markets</a></li><li id="menu-item-14618" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14618"><a href="https://www.geeskaafrika.com/category/kenya-news/">Kenya</a></li><li id="menu-item-29506" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29506"><a href="https://www.geeskaafrika.com/category/south-sudan/">South Sudan</a></li><li id="menu-item-14301" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-14301"><a href="https://www.geeskaafrika.com/category/world/">More<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-29593" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-29593"><a href="https://www.geeskaafrika.com/category/world-news/">World News</a></li><li id="menu-item-14818" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14818"><a href="https://www.geeskaafrika.com/category/opinion/">Opinion</a></li><li id="menu-item-4069" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4069"><a href="https://www.geeskaafrika.com/category/daily-security-briefing/">Daily Security Breif</a></li><li id="menu-item-4057" class="color1 menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-4057"><a href="https://www.geeskaafrika.com/category/press-release/">Press Releases</a></li><li id="menu-item-17140" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-17140"><a href="https://www.geeskaafrika.com/category/world/somaliland/">Somaliland</a></li><li id="menu-item-14282" class="color4 menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-14282"><a href="https://www.geeskaafrika.com/category/events/">Events</a></li><li id="menu-item-14303" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14303"><a href="https://www.geeskaafrika.com/category/world/sports/">Sports</a></li><li id="menu-item-14302" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14302"><a href="https://www.geeskaafrika.com/category/world/movies/">Video</a></li><li id="menu-item-15128" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15128"><a href="https://www.geeskaafrika.com/category/wararka-maanta/">Wararka Maanta</a></li></ul></li></ul></div></div></div></div><div class="td-search-background"></div><div class="td-search-wrap-mob"><div class="td-drop-down-search" aria-labelledby="td-header-search-button"><form method="get" class="td-search-form" action="https://www.geeskaafrika.com/"><div class="td-search-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div><div role="search" class="td-search-input"> <span>Search</span> <input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" /></div></form><div id="td-aj-search-mob"></div></div></div><div id="td-outer-wrap" class="td-theme-wrap"><div class="td-header-wrap td-header-style-10"><div class="td-header-top-menu-full td-container-wrap "><div class="td-container td-header-row td-header-top-menu"><div class="top-bar-style-4"><div class="td-header-sp-top-widget"> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.facebook.com/GeeskaAfrikaOnline" title="Facebook"> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://twitter.com/GeskaAfrika" title="Twitter"> <i class="td-icon-font td-icon-twitter"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="#" title="Vimeo"> <i class="td-icon-font td-icon-vimeo"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="#" title="VKontakte"> <i class="td-icon-font td-icon-vk"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="#" title="Youtube"> <i class="td-icon-font td-icon-youtube"></i> </a> </span></div><div class="td-header-sp-top-menu"><div class="td_data_time"><div > Monday, January 17, 2022</div></div><div class="menu-top-container"><ul id="menu-secondary-menu" class="top-header-menu"><li id="menu-item-30944" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-30944"><a href="https://www.geeskaafrika.com/become-a-contributor/">BECOME A CONTRIBUTOR</a></li><li id="menu-item-30948" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-30948"><a href="https://www.geeskaafrika.com/contact-us/">Contact Us</a></li></ul></div></div></div></div></div><div class="td-banner-wrap-full td-logo-wrap-full  td-container-wrap "><div class="td-header-sp-logo"> <a class="td-main-logo" href="https://www.geeskaafrika.com/"> <noscript><img class="td-retina-data"  data-retina="https://geeskaafrika.com/wp-content/uploads/2016/04/Geeks-Fixed-Logo-300x94.png" src="https://geeskaafrika.com/wp-content/uploads/2016/04/Geeks-Fixed-Logo-300x94.png" alt="" /></noscript><img class="lazyload td-retina-data"  data-retina="https://geeskaafrika.com/wp-content/uploads/2016/04/Geeks-Fixed-Logo-300x94.png" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20210%20140%22%3E%3C/svg%3E' data-src="https://geeskaafrika.com/wp-content/uploads/2016/04/Geeks-Fixed-Logo-300x94.png" alt="" /> <span class="td-visual-hidden">Geeska Afrika Online 1985-2022</span> </a></div></div><div class="td-header-menu-wrap-full td-container-wrap "><div class="td-header-menu-wrap td-header-gradient"><div class="td-container td-header-row td-header-main-menu"><div id="td-header-menu" role="navigation"><div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div><div class="td-main-menu-logo td-logo-in-header"> <a class="td-main-logo" href="https://www.geeskaafrika.com/"> <noscript><img class="td-retina-data" data-retina="https://geeskaafrika.com/wp-content/uploads/2016/04/Geeks-Fixed-Logo-300x94.png" src="https://geeskaafrika.com/wp-content/uploads/2016/04/Geeks-Fixed-Logo-300x94.png" alt=""/></noscript><img class="lazyload td-retina-data" data-retina="https://geeskaafrika.com/wp-content/uploads/2016/04/Geeks-Fixed-Logo-300x94.png" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20210%20140%22%3E%3C/svg%3E' data-src="https://geeskaafrika.com/wp-content/uploads/2016/04/Geeks-Fixed-Logo-300x94.png" alt=""/> </a></div><div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="sf-menu"><li class="home menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-4059"><a href="https://www.geeskaafrika.com">Home</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-14615"><a href="https://www.geeskaafrika.com/category/ethiopia-news/">Ethiopia</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-14617"><a href="https://www.geeskaafrika.com/category/eritrea-news/">Eritrea</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-14616"><a href="https://www.geeskaafrika.com/category/somalia/">Somalia</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-14619"><a href="https://www.geeskaafrika.com/category/sudan/">Sudan</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-15129"><a href="https://www.geeskaafrika.com/category/djibouti-news/">Djibouti</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-14621"><a href="https://www.geeskaafrika.com/category/uganda/">Uganda</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-14283"><a href="https://www.geeskaafrika.com/category/markets/">Markets</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-14618"><a href="https://www.geeskaafrika.com/category/kenya-news/">Kenya</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-29506"><a href="https://www.geeskaafrika.com/category/south-sudan/">South Sudan</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children td-menu-item td-normal-menu menu-item-14301"><a href="https://www.geeskaafrika.com/category/world/">More</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-29593"><a href="https://www.geeskaafrika.com/category/world-news/">World News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-14818"><a href="https://www.geeskaafrika.com/category/opinion/">Opinion</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-4069"><a href="https://www.geeskaafrika.com/category/daily-security-briefing/">Daily Security Breif</a></li><li class="color1 menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-4057"><a href="https://www.geeskaafrika.com/category/press-release/">Press Releases</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-17140"><a href="https://www.geeskaafrika.com/category/world/somaliland/">Somaliland</a></li><li class="color4 menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-14282"><a href="https://www.geeskaafrika.com/category/events/">Events</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-14303"><a href="https://www.geeskaafrika.com/category/world/sports/">Sports</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-14302"><a href="https://www.geeskaafrika.com/category/world/movies/">Video</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-15128"><a href="https://www.geeskaafrika.com/category/wararka-maanta/">Wararka Maanta</a></li></ul></li></ul></div></div><div class="td-search-wrapper"><div id="td-top-search"><div class="header-search-wrap"><div class="dropdown header-search"> <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a> <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a></div></div></div></div><div class="header-search-wrap"><div class="dropdown header-search"><div class="td-drop-down-search" aria-labelledby="td-header-search-button"><form method="get" class="td-search-form" action="https://www.geeskaafrika.com/"><div role="search" class="td-head-form-search-wrap"> <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" /></div></form><div id="td-aj-search"></div></div></div></div></div></div></div><div class="td-banner-wrap-full td-banner-bg td-container-wrap "><div class="td-container-header td-header-row td-header-header"><div class="td-header-sp-recs"><div class="td-header-rec-wrap"><div class="td-g-rec td-g-rec-id-header td_uid_1_61e5b3921fd5c_rand td_block_template_1 "> <script type="text/javascript">var td_screen_width = window.innerWidth;
if ( td_screen_width >= 1140 ) {
/* large monitors */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-5611073950577835" data-ad-slot="2951938503"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}
if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
/* landscape tablets */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-5611073950577835" data-ad-slot="2951938503"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}
if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
/* portrait tablets */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-5611073950577835" data-ad-slot="2951938503"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}
if ( td_screen_width < 768 ) {
/* Phones */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:320px;height:100px" data-ad-client="ca-pub-5611073950577835" data-ad-slot="2951938503"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}</script> </div></div></div></div></div></div><article id="post-33919" class="td-post-template-3 post-33919 post type-post status-publish format-standard has-post-thumbnail hentry category-ethiopia-news category-events category-frontpage category-latest-news category-press-release category-somalia category-somaliland category-world-news td-container-wrap" itemscope itemtype="https://schema.org/Article"><div class="td-post-header td-container"><div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://www.geeskaafrika.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Ethiopia" class="entry-crumb" href="https://www.geeskaafrika.com/category/ethiopia-news/">Ethiopia</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Somaliland to Join British Commonwealth Again:1954</span></div></div><div class="td-post-header-holder td-image-gradient"><div class="td-post-featured-image"><a href="https://www.geeskaafrika.com/wp-content/uploads/2022/01/egal_1954.jpg" data-caption=""><noscript><img width="720" height="578" class="entry-thumb td-modal-image" src="https://www.geeskaafrika.com/wp-content/uploads/2022/01/egal_1954.jpg" srcset="https://www.geeskaafrika.com/wp-content/uploads/2022/01/egal_1954.jpg 720w, https://www.geeskaafrika.com/wp-content/uploads/2022/01/egal_1954-300x241.jpg 300w, https://www.geeskaafrika.com/wp-content/uploads/2022/01/egal_1954-696x559.jpg 696w, https://www.geeskaafrika.com/wp-content/uploads/2022/01/egal_1954-523x420.jpg 523w, https://www.geeskaafrika.com/wp-content/uploads/2022/01/egal_1954-560x450.jpg 560w" sizes="(max-width: 720px) 100vw, 720px" alt="" title="egal_1954"/></noscript><img width="720" height="578" class="lazyload entry-thumb td-modal-image" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20720%20578%22%3E%3C/svg%3E' data-src="https://www.geeskaafrika.com/wp-content/uploads/2022/01/egal_1954.jpg" data-srcset="https://www.geeskaafrika.com/wp-content/uploads/2022/01/egal_1954.jpg 720w, https://www.geeskaafrika.com/wp-content/uploads/2022/01/egal_1954-300x241.jpg 300w, https://www.geeskaafrika.com/wp-content/uploads/2022/01/egal_1954-696x559.jpg 696w, https://www.geeskaafrika.com/wp-content/uploads/2022/01/egal_1954-523x420.jpg 523w, https://www.geeskaafrika.com/wp-content/uploads/2022/01/egal_1954-560x450.jpg 560w" data-sizes="(max-width: 720px) 100vw, 720px" alt="" title="egal_1954"/></a></div><header class="td-post-title"><ul class="td-category"><li class="entry-category"><a  href="https://www.geeskaafrika.com/category/ethiopia-news/">Ethiopia</a></li><li class="entry-category"><a  href="https://www.geeskaafrika.com/category/events/">Events</a></li><li class="entry-category"><a  href="https://www.geeskaafrika.com/category/frontpage/">frontpage</a></li><li class="entry-category"><a  href="https://www.geeskaafrika.com/category/latest-news/">Latest News</a></li><li class="entry-category"><a  href="https://www.geeskaafrika.com/category/press-release/">Press Release</a></li><li class="entry-category"><a  href="https://www.geeskaafrika.com/category/somalia/">Somalia</a></li><li class="entry-category"><a  href="https://www.geeskaafrika.com/category/world/">world</a></li><li class="entry-category"><a  href="https://www.geeskaafrika.com/category/world/somaliland/">Somaliland</a></li><li class="entry-category"><a  href="https://www.geeskaafrika.com/category/world-news/">World News</a></li></ul><h1 class="entry-title">Somaliland to Join British Commonwealth Again:1954</h1><div class="td-module-meta-info"> <span class="td-post-date td-post-date-no-dot"><time class="entry-date updated td-module-date" datetime="2022-01-17T04:37:06+00:00" >17 January 2022</time></span></div></header></div></div><div class="td-container"><div class="td-pb-row"><div class="td-pb-span8 td-main-content" role="main"><div class="td-ss-main-content"><div class="td-post-sharing td-post-sharing-top "><div class="td-default-sharing"> <a class="td-social-sharing-buttons td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.geeskaafrika.com%2Fsomaliland-to-join-british-commonwealth-again1954%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-facebook"></i><div class="td-social-but-text">Share on Facebook</div></a> <a class="td-social-sharing-buttons td-social-twitter" href="https://twitter.com/intent/tweet?text=Somaliland+to+Join+British+Commonwealth+Again%3A1954&url=https%3A%2F%2Fwww.geeskaafrika.com%2Fsomaliland-to-join-british-commonwealth-again1954%2F&via=GeskaAfrika"  ><i class="td-icon-twitter"></i><div class="td-social-but-text">Tweet on Twitter</div></a> <a class="td-social-sharing-buttons td-social-google" href="https://plus.google.com/share?url=https://www.geeskaafrika.com/somaliland-to-join-british-commonwealth-again1954/" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-googleplus"></i></a> <a class="td-social-sharing-buttons td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://www.geeskaafrika.com/somaliland-to-join-british-commonwealth-again1954/&amp;media=https://www.geeskaafrika.com/wp-content/uploads/2022/01/egal_1954.jpg&description=Somaliland+to+Join+British+Commonwealth+Again%3A1954" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-pinterest"></i></a> <a class="td-social-sharing-buttons td-social-whatsapp" href="whatsapp://send?text=Somaliland+to+Join+British+Commonwealth+Again%3A1954%20-%20https%3A%2F%2Fwww.geeskaafrika.com%2Fsomaliland-to-join-british-commonwealth-again1954%2F" ><i class="td-icon-whatsapp"></i></a></div></div><div class="td-post-content"><div class="td-g-rec td-g-rec-id-content_top td_uid_3_61e5b39220f9c_rand td_block_template_1 "> <script type="text/javascript">var td_screen_width = window.innerWidth;
if ( td_screen_width >= 1140 ) {
/* large monitors */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-5611073950577835" data-ad-slot="8638655705"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}
if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
/* landscape tablets */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-5611073950577835" data-ad-slot="8638655705"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}
if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
/* portrait tablets */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-5611073950577835" data-ad-slot="8638655705"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}
if ( td_screen_width < 768 ) {
/* Phones */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-5611073950577835" data-ad-slot="8638655705"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}</script> </div><p><strong>London (HAN) 17 January 2022 &#8211; Diplomacy and Regional Security Issues for The latest news and announcements including. </strong>President of Rwanda, and Commonwealth Secretary-General, The Rt. Hon. Patricia Scotland QC, have announced the postponement of CHOGM 2021 as a result of the continuing impact of the Covid-19 pandemic.</p><p>Leaders of the Commonwealth countries meet every 2 years at the Commonwealth Heads of Government Meeting.</p><h2>Somaliland: Its Eligibility criteria roots goes back to the British Empire in Febuary1954</h2><p>Ambassador Kate Foster, in her first visit to Somaliland, launches construction of the Hargeisa bypass for future UK strategy for Somaliland and its strategic initiatives.</p><p>At the Commonwealth Heads of Government Meeting in Uganda, Heads of Government reviewed the recommendations of the Committee on Commonwealth Membership and agreed on the following core criteria for Membership and Somaliland issue:</p><p>An applicant country should, as a general rule, have had a historic constitutional association with an existing Commonwealth member, save in exceptional circumstances, since Somaliland were part of Commonwealth in February 1954, after Haile Sillase agreement to give Hawd &amp; Reserved area (was originally part of Greater British Somaliland zones).</p><ul><li>in exceptional circumstances, applications should be considered on a case-by-case basis</li><li>an applicant country should accept and comply with Commonwealth fundamental values, principles, and priorities as set out in the 1971 Declaration of Commonwealth Principles and contained in other subsequent Declarations</li></ul><p><em>Published under Creative Commons Attribution-NonCommercial 4.0 International <a href="https://creativecommons.org/licenses/by-nc/4.0/" target="_blank" rel="noopener external noreferrer" data-wpel-link="external">licence</a>. Cite Geeska Afrika and link to this page if republished.</em></p><div class="ss-inline-share-wrapper ss-left-inline-content ss-large-icons ss-with-spacing ss-circle-icons"><div class="td-g-rec td-g-rec-id-content_inline td_uid_2_61e5b39220f61_rand td_block_template_1 "> <script type="text/javascript">var td_screen_width = window.innerWidth;
if ( td_screen_width < 768 ) {
/* Phones */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-5611073950577835" data-ad-slot="8998472103"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}</script> </div><p class="ss-social-share-label"> <span>Share via:</span></p><div class="ss-inline-share-content"><ul class="ss-social-icons-container"><li class=""> <a href="#" data-ss-ss-link="https://www.facebook.com/sharer.php?t=Somaliland%20to%20Join%20British%20Commonwealth%20Again%3A1954&#038;u=https%3A%2F%2Fwww.geeskaafrika.com%2Fsomaliland-to-join-british-commonwealth-again1954%2F" class="ss-facebook-color" rel="nofollow noopener" data-ss-ss-network-id="facebook" data-ss-ss-post-id="33919" data-ss-ss-location="inline_content" data-ss-ss-permalink="https://www.geeskaafrika.com/somaliland-to-join-british-commonwealth-again1954/" data-ss-ss-type="share" data-has-api="true"> <span class="ss-share-network-content"> <i class="ss-network-icon"><svg class="ss-svg-icon" aria-hidden="true" role="img" focusable="false" width="32" height="32" viewBox="0 0 32 32" xmlns="http://www.w3.org/2000/svg"><path d="M32 16.098C32 7.208 24.837 0 16 0S0 7.207 0 16.098C0 24.133 5.851 30.792 13.5 32V20.751H9.437v-4.653H13.5V12.55c0-4.034 2.389-6.263 6.043-6.263 1.751 0 3.582.315 3.582.315v3.961h-2.018c-1.987 0-2.607 1.241-2.607 2.514v3.02h4.438l-.71 4.653H18.5V32C26.149 30.792 32 24.133 32 16.098z" /></svg></i> <span class="ss-network-label">Facebook</span> </span> </a></li><li class=""> <a href="#" data-ss-ss-link="https://twitter.com/intent/tweet?text=Somaliland+to+Join+British+Commonwealth+Again%3A1954&#038;url=https%3A%2F%2Fwww.geeskaafrika.com%2Fsomaliland-to-join-british-commonwealth-again1954%2F" class="ss-twitter-color" rel="nofollow noopener" data-ss-ss-network-id="twitter" data-ss-ss-post-id="33919" data-ss-ss-location="inline_content" data-ss-ss-permalink="https://www.geeskaafrika.com/somaliland-to-join-british-commonwealth-again1954/" data-ss-ss-type="share"> <span class="ss-share-network-content"> <i class="ss-network-icon"><svg class="ss-svg-icon" aria-hidden="true" role="img" focusable="false" width="32" height="32" viewBox="0 0 32 32" xmlns="http://www.w3.org/2000/svg"><path d="M28.75 9.5c0 0.25 0 0.563 0 0.813 0 8.688-6.625 18.688-18.688 18.688-3.688 0-7.188-1.063-10.063-2.938 0.5 0.063 1.063 0.063 1.563 0.063 3.063 0 5.938-1 8.188-2.813-2.875 0-5.313-1.938-6.188-4.563 0.438 0.125 0.813 0.125 1.25 0.125 0.625 0 1.188-0.063 1.75-0.188-3-0.625-5.25-3.313-5.25-6.438 0-0.063 0-0.063 0-0.125 0.875 0.5 1.875 0.813 2.938 0.813-1.75-1.125-2.938-3.188-2.938-5.438 0-1.188 0.375-2.313 0.938-3.313 3.188 4 8.063 6.625 13.5 6.875-0.125-0.5-0.188-1-0.188-1.5 0-3.625 2.938-6.563 6.563-6.563 1.938 0 3.625 0.813 4.813 2.063 1.5-0.313 2.938-0.813 4.188-1.563-0.5 1.5-1.563 2.813-2.875 3.625 1.313-0.188 2.563-0.5 3.75-1.063-0.875 1.313-2 2.5-3.25 3.438z"></path></svg></i> <span class="ss-network-label">Twitter</span> </span> </a></li><li class=""> <a href="#" data-ss-ss-link="https://www.linkedin.com/shareArticle?title=Somaliland%20to%20Join%20British%20Commonwealth%20Again%3A1954&#038;url=https%3A%2F%2Fwww.geeskaafrika.com%2Fsomaliland-to-join-british-commonwealth-again1954%2F&#038;mini=true" class="ss-linkedin-color" rel="nofollow noopener" data-ss-ss-network-id="linkedin" data-ss-ss-post-id="33919" data-ss-ss-location="inline_content" data-ss-ss-permalink="https://www.geeskaafrika.com/somaliland-to-join-british-commonwealth-again1954/" data-ss-ss-type="share"> <span class="ss-share-network-content"> <i class="ss-network-icon"><svg class="ss-svg-icon" aria-hidden="true" role="img" focusable="false" width="32" height="32" viewBox="0 0 32 32" xmlns="http://www.w3.org/2000/svg"><path fill-rule="evenodd" d="M29.632 0C30.939 0 32 1.032 32 2.307v27.384C32 30.966 30.939 32 29.632 32H2.36C1.058 32 0 30.966 0 29.69V2.308C0 1.032 1.058 0 2.36 0h27.272zM9.149 11.638h-4.77V27h4.77V11.638zm12.133-.382c-2.318 0-3.874 1.273-4.509 2.48h-.066v-2.098H12.14V27h4.76v-7.599c0-2.004.378-3.946 2.858-3.946 2.447 0 2.475 2.29 2.475 4.072V27H27v-8.423c0-4.138-.893-7.32-5.718-7.32v-.001zM6.764 4A2.766 2.766 0 004 6.769a2.765 2.765 0 105.528 0A2.767 2.767 0 006.765 4h-.001z" /></svg></i> <span class="ss-network-label">LinkedIn</span> </span> </a></li><li class=""> <a href="#" data-ss-ss-link="mailto:?body=https%3A%2F%2Fwww.geeskaafrika.com%2Fsomaliland-to-join-british-commonwealth-again1954%2F&#038;subject=Somaliland%20to%20Join%20British%20Commonwealth%20Again%3A1954" class="ss-envelope-color" rel="nofollow noopener" data-ss-ss-network-id="envelope" data-ss-ss-post-id="33919" data-ss-ss-location="inline_content" data-ss-ss-permalink="https://www.geeskaafrika.com/somaliland-to-join-british-commonwealth-again1954/" data-ss-ss-type="share"> <span class="ss-share-network-content"> <i class="ss-network-icon"><svg class="ss-svg-icon" aria-hidden="true" role="img" focusable="false" width="32" height="32" viewBox="0 0 32 32" xmlns="http://www.w3.org/2000/svg"><path d="M32 12.964v14.179c0 1.571-1.286 2.857-2.857 2.857h-26.286c-1.571 0-2.857-1.286-2.857-2.857v-14.179c0.536 0.589 1.143 1.107 1.804 1.554 2.964 2.018 5.964 4.036 8.875 6.161 1.5 1.107 3.357 2.464 5.304 2.464h0.036c1.946 0 3.804-1.357 5.304-2.464 2.911-2.107 5.911-4.143 8.893-6.161 0.643-0.446 1.25-0.964 1.786-1.554zM32 7.714c0 2-1.482 3.804-3.054 4.893-2.786 1.929-5.589 3.857-8.357 5.804-1.161 0.804-3.125 2.446-4.571 2.446h-0.036c-1.446 0-3.411-1.643-4.571-2.446-2.768-1.946-5.571-3.875-8.339-5.804-1.268-0.857-3.071-2.875-3.071-4.5 0-1.75 0.946-3.25 2.857-3.25h26.286c1.554 0 2.857 1.286 2.857 2.857z"></path></svg></i> <span class="ss-network-label">Email</span> </span> </a></li><li class=""> <a href="#" data-ss-ss-link="https://www.geeskaafrika.com/somaliland-to-join-british-commonwealth-again1954/" class="ss-copy-color" rel="nofollow noopener" data-ss-ss-network-id="copy" data-ss-ss-post-id="33919" data-ss-ss-location="inline_content" data-ss-ss-permalink="https://www.geeskaafrika.com/somaliland-to-join-british-commonwealth-again1954/" data-ss-ss-type="share"> <span class="ss-share-network-content"> <i class="ss-network-icon"><svg class="ss-svg-icon" aria-hidden="true" role="img" focusable="false" width="32" height="32" viewBox="0 0 32 32" xmlns="http://www.w3.org/2000/svg"><path d="M25.313 28v-18.688h-14.625v18.688h14.625zM25.313 6.688c1.438 0 2.688 1.188 2.688 2.625v18.688c0 1.438-1.25 2.688-2.688 2.688h-14.625c-1.438 0-2.688-1.25-2.688-2.688v-18.688c0-1.438 1.25-2.625 2.688-2.625h14.625zM21.313 1.313v2.688h-16v18.688h-2.625v-18.688c0-1.438 1.188-2.688 2.625-2.688h16z"></path></svg></i> <span class="ss-network-label">Copy Link</span> </span> </a></li><li> <a href="#" class="ss-share-all ss-shareall-color" rel="nofollow noopener"> <span class="ss-share-network-content"> <i class="ss-network-icon"><svg class="ss-svg-icon" aria-hidden="true" role="img" focusable="false" width="32" height="32" viewBox="0 0 32 32" xmlns="http://www.w3.org/2000/svg"><path d="M25.333 15.333h-8v-8c0-0.733-0.6-1.333-1.333-1.333s-1.333 0.6-1.333 1.333v8h-8c-0.733 0-1.333 0.6-1.333 1.333s0.6 1.333 1.333 1.333h8v8c0 0.733 0.6 1.333 1.333 1.333s1.333-0.6 1.333-1.333v-8h8c0.733 0 1.333-0.6 1.333-1.333s-0.6-1.333-1.333-1.333z"></path></svg></i> <span class="ss-reveal-label-wrap"> <span class="ss-network-label">More</span> </span> </span> </a></li></ul></div></div></div><footer><div class="td-post-source-tags"></div><div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://www.geeskaafrika.com/africa-security-briefing-and-consultations/">Africa: Security Briefing and Consultations</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="https://www.geeskaafrika.com/somaliland-the-indian-navy-deployed-under-the-charter-of-world-food-programm/">Somaliland: The Indian Navy Deployed under the charter of World Food Programm</a></div></div></div><div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="https://www.geeskaafrika.com/author/geeskadmin/">geeskaadmin</a></span></div> <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="geeskaadmin"></span><meta itemprop="datePublished" content="2022-01-17T04:37:06+00:00"><meta itemprop="dateModified" content="2022-01-17T05:16:17-05:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.geeskaafrika.com/somaliland-to-join-british-commonwealth-again1954/"/><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://geeskaafrika.com/wp-content/uploads/2016/04/Geeks-Fixed-Logo-300x94.png"></span><meta itemprop="name" content="Geeska Afrika Online 1985-2022"></span><meta itemprop="headline " content="Somaliland to Join British Commonwealth Again:1954"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.geeskaafrika.com/wp-content/uploads/2022/01/egal_1954.jpg"><meta itemprop="width" content="720"><meta itemprop="height" content="578"></span></footer><div class="td_block_wrap td_block_related_posts td_uid_4_61e5b39221419_rand td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_4_61e5b39221419" ><script>var block_td_uid_4_61e5b39221419 = new tdBlock();
block_td_uid_4_61e5b39221419.id = "td_uid_4_61e5b39221419";
block_td_uid_4_61e5b39221419.atts = '{"limit":3,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_custom_related","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_4_61e5b39221419_rand","el_class":"","offset":"","css":"","tdc_css":"","tdc_css_class":"td_uid_4_61e5b39221419_rand","tdc_css_class_style":"td_uid_4_61e5b39221419_rand_style","live_filter":"cur_post_same_categories","live_filter_cur_post_id":33919,"live_filter_cur_post_author":"2","block_template_id":""}';
block_td_uid_4_61e5b39221419.td_column_number = "3";
block_td_uid_4_61e5b39221419.block_type = "td_block_related_posts";
block_td_uid_4_61e5b39221419.post_count = "3";
block_td_uid_4_61e5b39221419.found_posts = "7171";
block_td_uid_4_61e5b39221419.header_color = "";
block_td_uid_4_61e5b39221419.ajax_pagination_infinite_stop = "";
block_td_uid_4_61e5b39221419.max_num_pages = "2391";
tdBlocksArray.push(block_td_uid_4_61e5b39221419);</script><h4 class="td-related-title td-block-title"><a id="td_uid_5_61e5b3922a70f" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_4_61e5b39221419" href="#">RELATED ARTICLES</a><a id="td_uid_6_61e5b3922a712" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_4_61e5b39221419" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_4_61e5b39221419 class="td_block_inner"><div class="td-related-row"><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.geeskaafrika.com/ethiopia-eucap-concerned-anti-piracy-mandate-off-somalia/" rel="bookmark" title="Ethiopia: EUCap Concerned Anti-Piracy Mandate off Somalia"><noscript><img width="218" height="150" class="entry-thumb" src="https://www.geeskaafrika.com/wp-content/uploads/2022/01/EU_somalia_maritime-218x150.jpg" srcset="https://www.geeskaafrika.com/wp-content/uploads/2022/01/EU_somalia_maritime-218x150.jpg 218w, https://www.geeskaafrika.com/wp-content/uploads/2022/01/EU_somalia_maritime-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Ethiopia: EUCap Concerned Anti-Piracy Mandate off Somalia"/></noscript><img width="218" height="150" class="lazyload entry-thumb" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20218%20150%22%3E%3C/svg%3E' data-src="https://www.geeskaafrika.com/wp-content/uploads/2022/01/EU_somalia_maritime-218x150.jpg" data-srcset="https://www.geeskaafrika.com/wp-content/uploads/2022/01/EU_somalia_maritime-218x150.jpg 218w, https://www.geeskaafrika.com/wp-content/uploads/2022/01/EU_somalia_maritime-100x70.jpg 100w" data-sizes="(max-width: 218px) 100vw, 218px" alt="" title="Ethiopia: EUCap Concerned Anti-Piracy Mandate off Somalia"/></a></div> <a href="https://www.geeskaafrika.com/category/daily-security-briefing/" class="td-post-category">Daily Security Briefing</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.geeskaafrika.com/ethiopia-eucap-concerned-anti-piracy-mandate-off-somalia/" rel="bookmark" title="Ethiopia: EUCap Concerned Anti-Piracy Mandate off Somalia">Ethiopia: EUCap Concerned Anti-Piracy Mandate off Somalia</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.geeskaafrika.com/somaliland-the-indian-navy-deployed-under-the-charter-of-world-food-programm/" rel="bookmark" title="Somaliland: The Indian Navy Deployed under the charter of World Food Programm"><noscript><img width="218" height="150" class="entry-thumb" src="https://www.geeskaafrika.com/wp-content/uploads/2022/01/eucap-218x150.jpg" srcset="https://www.geeskaafrika.com/wp-content/uploads/2022/01/eucap-218x150.jpg 218w, https://www.geeskaafrika.com/wp-content/uploads/2022/01/eucap-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Somaliland: The Indian Navy Deployed under the charter of World Food Programm"/></noscript><img width="218" height="150" class="lazyload entry-thumb" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20218%20150%22%3E%3C/svg%3E' data-src="https://www.geeskaafrika.com/wp-content/uploads/2022/01/eucap-218x150.jpg" data-srcset="https://www.geeskaafrika.com/wp-content/uploads/2022/01/eucap-218x150.jpg 218w, https://www.geeskaafrika.com/wp-content/uploads/2022/01/eucap-100x70.jpg 100w" data-sizes="(max-width: 218px) 100vw, 218px" alt="" title="Somaliland: The Indian Navy Deployed under the charter of World Food Programm"/></a></div> <a href="https://www.geeskaafrika.com/category/daily-security-briefing/" class="td-post-category">Daily Security Briefing</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.geeskaafrika.com/somaliland-the-indian-navy-deployed-under-the-charter-of-world-food-programm/" rel="bookmark" title="Somaliland: The Indian Navy Deployed under the charter of World Food Programm">Somaliland: The Indian Navy Deployed under the charter of World Food Programm</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.geeskaafrika.com/africa-security-briefing-and-consultations/" rel="bookmark" title="Africa: Security Briefing and Consultations"><noscript><img width="218" height="150" class="entry-thumb" src="https://www.geeskaafrika.com/wp-content/uploads/2022/01/Mahamat-Saleh-Annadif-218x150.jpg" srcset="https://www.geeskaafrika.com/wp-content/uploads/2022/01/Mahamat-Saleh-Annadif-218x150.jpg 218w, https://www.geeskaafrika.com/wp-content/uploads/2022/01/Mahamat-Saleh-Annadif-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Mahamat Saleh Annadif" title="Africa: Security Briefing and Consultations"/></noscript><img width="218" height="150" class="lazyload entry-thumb" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20218%20150%22%3E%3C/svg%3E' data-src="https://www.geeskaafrika.com/wp-content/uploads/2022/01/Mahamat-Saleh-Annadif-218x150.jpg" data-srcset="https://www.geeskaafrika.com/wp-content/uploads/2022/01/Mahamat-Saleh-Annadif-218x150.jpg 218w, https://www.geeskaafrika.com/wp-content/uploads/2022/01/Mahamat-Saleh-Annadif-100x70.jpg 100w" data-sizes="(max-width: 218px) 100vw, 218px" alt="Mahamat Saleh Annadif" title="Africa: Security Briefing and Consultations"/></a></div> <a href="https://www.geeskaafrika.com/category/daily-security-briefing/" class="td-post-category">Daily Security Briefing</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.geeskaafrika.com/africa-security-briefing-and-consultations/" rel="bookmark" title="Africa: Security Briefing and Consultations">Africa: Security Briefing and Consultations</a></h3></div></div></div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_4_61e5b39221419" data-td_block_id="td_uid_4_61e5b39221419"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_4_61e5b39221419" data-td_block_id="td_uid_4_61e5b39221419"><i class="td-icon-font td-icon-menu-right"></i></a></div></div><div class="comments" id="comments"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">LEAVE A REPLY <small><a rel="nofollow" id="cancel-comment-reply-link" href="/somaliland-to-join-british-commonwealth-again1954/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.geeskaafrika.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><div class="clearfix"></div><div class="comment-form-input-wrap td-form-comment"><textarea placeholder="Comment:" id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea><div class="td-warning-comment">Please enter your comment!</div></div><div class="comment-form-input-wrap td-form-author"> <input class="" id="author" name="author" placeholder="Name:*" type="text" value="" size="30"  aria-required='true' /><div class="td-warning-author">Please enter your name here</div></div><div class="comment-form-input-wrap td-form-email"> <input class="" id="email" name="email" placeholder="Email:*" type="text" value="" size="30"  aria-required='true' /><div class="td-warning-email-error">You have entered an incorrect email address!</div><div class="td-warning-email">Please enter your email address here</div></div><div class="comment-form-input-wrap td-form-url"> <input class="" id="url" name="url" placeholder="Website:" type="text" value="" size="30" /></div><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='33919' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="c92c47ff06" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js" name="ak_js" value="226"/><script>document.getElementById( "ak_js" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form></div></div></div></div><div class="td-pb-span4 td-main-sidebar" role="complementary"><div class="td-ss-main-sidebar"><div class="td-g-rec td-g-rec-id-sidebar td_uid_7_61e5b3922b39f_rand td_block_template_1 "> <script type="text/javascript">var td_screen_width = window.innerWidth;
if ( td_screen_width >= 1140 ) {
/* large monitors */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:160px;height:600px" data-ad-client="ca-pub-5611073950577835" data-ad-slot="8998472103"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}
if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
/* landscape tablets */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:160px;height:600px" data-ad-client="ca-pub-5611073950577835" data-ad-slot="8998472103"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}
if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
/* portrait tablets */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:160px;height:600px" data-ad-client="ca-pub-5611073950577835" data-ad-slot="8998472103"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}</script> </div><div class="td_block_wrap td_block_7 td_block_widget td_uid_8_61e5b3922b41e_rand td-pb-border-top td_block_template_1 td-column-1 td_block_padding"  data-td-block-uid="td_uid_8_61e5b3922b41e" ><script>var block_td_uid_8_61e5b3922b41e = new tdBlock();
block_td_uid_8_61e5b3922b41e.id = "td_uid_8_61e5b3922b41e";
block_td_uid_8_61e5b3922b41e.atts = '{"limit":"5","sort":"random_7_day","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"Recent Articles ","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"","header_color":"#","header_text_color":"#","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_block_widget td_uid_8_61e5b3922b41e_rand","el_class":"","offset":"","css":"","tdc_css":"","tdc_css_class":"td_uid_8_61e5b3922b41e_rand","tdc_css_class_style":"td_uid_8_61e5b3922b41e_rand_style","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":"","block_template_id":""}';
block_td_uid_8_61e5b3922b41e.td_column_number = "1";
block_td_uid_8_61e5b3922b41e.block_type = "td_block_7";
block_td_uid_8_61e5b3922b41e.post_count = "5";
block_td_uid_8_61e5b3922b41e.found_posts = "5";
block_td_uid_8_61e5b3922b41e.header_color = "#";
block_td_uid_8_61e5b3922b41e.ajax_pagination_infinite_stop = "";
block_td_uid_8_61e5b3922b41e.max_num_pages = "1";
tdBlocksArray.push(block_td_uid_8_61e5b3922b41e);</script><div class="td-block-title-wrap"><h4 class="block-title"><span class="td-pulldown-size">Recent Articles </span></h4></div><div id=td_uid_8_61e5b3922b41e class="td_block_inner"><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.geeskaafrika.com/somaliland-the-indian-navy-deployed-under-the-charter-of-world-food-programm/" rel="bookmark" title="Somaliland: The Indian Navy Deployed under the charter of World Food Programm"><noscript><img width="100" height="70" class="entry-thumb" src="https://www.geeskaafrika.com/wp-content/uploads/2022/01/eucap-100x70.jpg" srcset="https://www.geeskaafrika.com/wp-content/uploads/2022/01/eucap-100x70.jpg 100w, https://www.geeskaafrika.com/wp-content/uploads/2022/01/eucap-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Somaliland: The Indian Navy Deployed under the charter of World Food Programm"/></noscript><img width="100" height="70" class="lazyload entry-thumb" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20100%2070%22%3E%3C/svg%3E' data-src="https://www.geeskaafrika.com/wp-content/uploads/2022/01/eucap-100x70.jpg" data-srcset="https://www.geeskaafrika.com/wp-content/uploads/2022/01/eucap-100x70.jpg 100w, https://www.geeskaafrika.com/wp-content/uploads/2022/01/eucap-218x150.jpg 218w" data-sizes="(max-width: 100px) 100vw, 100px" alt="" title="Somaliland: The Indian Navy Deployed under the charter of World Food Programm"/></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.geeskaafrika.com/somaliland-the-indian-navy-deployed-under-the-charter-of-world-food-programm/" rel="bookmark" title="Somaliland: The Indian Navy Deployed under the charter of World Food Programm">Somaliland: The Indian Navy Deployed under the charter of World Food...</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-01-17T13:00:11+00:00" >17 January 2022</time></span></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.geeskaafrika.com/ethiopia-eucap-concerned-anti-piracy-mandate-off-somalia/" rel="bookmark" title="Ethiopia: EUCap Concerned Anti-Piracy Mandate off Somalia"><noscript><img width="100" height="70" class="entry-thumb" src="https://www.geeskaafrika.com/wp-content/uploads/2022/01/EU_somalia_maritime-100x70.jpg" srcset="https://www.geeskaafrika.com/wp-content/uploads/2022/01/EU_somalia_maritime-100x70.jpg 100w, https://www.geeskaafrika.com/wp-content/uploads/2022/01/EU_somalia_maritime-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Ethiopia: EUCap Concerned Anti-Piracy Mandate off Somalia"/></noscript><img width="100" height="70" class="lazyload entry-thumb" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20100%2070%22%3E%3C/svg%3E' data-src="https://www.geeskaafrika.com/wp-content/uploads/2022/01/EU_somalia_maritime-100x70.jpg" data-srcset="https://www.geeskaafrika.com/wp-content/uploads/2022/01/EU_somalia_maritime-100x70.jpg 100w, https://www.geeskaafrika.com/wp-content/uploads/2022/01/EU_somalia_maritime-218x150.jpg 218w" data-sizes="(max-width: 100px) 100vw, 100px" alt="" title="Ethiopia: EUCap Concerned Anti-Piracy Mandate off Somalia"/></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.geeskaafrika.com/ethiopia-eucap-concerned-anti-piracy-mandate-off-somalia/" rel="bookmark" title="Ethiopia: EUCap Concerned Anti-Piracy Mandate off Somalia">Ethiopia: EUCap Concerned Anti-Piracy Mandate off Somalia</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-01-17T13:13:30+00:00" >17 January 2022</time></span></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.geeskaafrika.com/africa-security-briefing-and-consultations/" rel="bookmark" title="Africa: Security Briefing and Consultations"><noscript><img width="100" height="70" class="entry-thumb" src="https://www.geeskaafrika.com/wp-content/uploads/2022/01/Mahamat-Saleh-Annadif-100x70.jpg" srcset="https://www.geeskaafrika.com/wp-content/uploads/2022/01/Mahamat-Saleh-Annadif-100x70.jpg 100w, https://www.geeskaafrika.com/wp-content/uploads/2022/01/Mahamat-Saleh-Annadif-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="Mahamat Saleh Annadif" title="Africa: Security Briefing and Consultations"/></noscript><img width="100" height="70" class="lazyload entry-thumb" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20100%2070%22%3E%3C/svg%3E' data-src="https://www.geeskaafrika.com/wp-content/uploads/2022/01/Mahamat-Saleh-Annadif-100x70.jpg" data-srcset="https://www.geeskaafrika.com/wp-content/uploads/2022/01/Mahamat-Saleh-Annadif-100x70.jpg 100w, https://www.geeskaafrika.com/wp-content/uploads/2022/01/Mahamat-Saleh-Annadif-218x150.jpg 218w" data-sizes="(max-width: 100px) 100vw, 100px" alt="Mahamat Saleh Annadif" title="Africa: Security Briefing and Consultations"/></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.geeskaafrika.com/africa-security-briefing-and-consultations/" rel="bookmark" title="Africa: Security Briefing and Consultations">Africa: Security Briefing and Consultations</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-01-11T11:03:48+00:00" >11 January 2022</time></span></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.geeskaafrika.com/somaliland-foreign-minister-their-is-no-somalia-state/" rel="bookmark" title="Somaliland Foreign Minister &#8220;Their is no Somalia State&#8221;"><noscript><img width="100" height="70" class="entry-thumb" src="https://www.geeskaafrika.com/wp-content/uploads/2022/01/Essa-Kayd-100x70.jpg" srcset="https://www.geeskaafrika.com/wp-content/uploads/2022/01/Essa-Kayd-100x70.jpg 100w, https://www.geeskaafrika.com/wp-content/uploads/2022/01/Essa-Kayd-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="Foreign Minister, Essa Kayd" title="Somaliland Foreign Minister &#8220;Their is no Somalia State&#8221;"/></noscript><img width="100" height="70" class="lazyload entry-thumb" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20100%2070%22%3E%3C/svg%3E' data-src="https://www.geeskaafrika.com/wp-content/uploads/2022/01/Essa-Kayd-100x70.jpg" data-srcset="https://www.geeskaafrika.com/wp-content/uploads/2022/01/Essa-Kayd-100x70.jpg 100w, https://www.geeskaafrika.com/wp-content/uploads/2022/01/Essa-Kayd-218x150.jpg 218w" data-sizes="(max-width: 100px) 100vw, 100px" alt="Foreign Minister, Essa Kayd" title="Somaliland Foreign Minister &#8220;Their is no Somalia State&#8221;"/></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.geeskaafrika.com/somaliland-foreign-minister-their-is-no-somalia-state/" rel="bookmark" title="Somaliland Foreign Minister &#8220;Their is no Somalia State&#8221;">Somaliland Foreign Minister &#8220;Their is no Somalia State&#8221;</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-01-11T10:53:54+00:00" >11 January 2022</time></span></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.geeskaafrika.com/somaliland-to-join-british-commonwealth-again1954/" rel="bookmark" title="Somaliland to Join British Commonwealth Again:1954"><noscript><img width="100" height="70" class="entry-thumb" src="https://www.geeskaafrika.com/wp-content/uploads/2022/01/egal_1954-100x70.jpg" srcset="https://www.geeskaafrika.com/wp-content/uploads/2022/01/egal_1954-100x70.jpg 100w, https://www.geeskaafrika.com/wp-content/uploads/2022/01/egal_1954-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Somaliland to Join British Commonwealth Again:1954"/></noscript><img width="100" height="70" class="lazyload entry-thumb" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20100%2070%22%3E%3C/svg%3E' data-src="https://www.geeskaafrika.com/wp-content/uploads/2022/01/egal_1954-100x70.jpg" data-srcset="https://www.geeskaafrika.com/wp-content/uploads/2022/01/egal_1954-100x70.jpg 100w, https://www.geeskaafrika.com/wp-content/uploads/2022/01/egal_1954-218x150.jpg 218w" data-sizes="(max-width: 100px) 100vw, 100px" alt="" title="Somaliland to Join British Commonwealth Again:1954"/></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.geeskaafrika.com/somaliland-to-join-british-commonwealth-again1954/" rel="bookmark" title="Somaliland to Join British Commonwealth Again:1954">Somaliland to Join British Commonwealth Again:1954</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-01-17T04:37:06+00:00" >17 January 2022</time></span></div></div></div></div></div></div><div class="td_block_wrap td_block_social_counter td_block_widget td_uid_9_61e5b39232100_rand td-pb-border-top td_block_template_1"><div class="td-block-title-wrap"><h4 class="block-title"><span class="td-pulldown-size">STAY CONNECTED</span></h4></div><div class="td-social-list"><div class="td_social_type td-pb-margin-side td_social_facebook"><div class="td-social-box"><div class="td-sp td-sp-facebook"></div><span class="td_social_info">3,937</span><span class="td_social_info td_social_info_name">Fans</span><span class="td_social_button"><a href="https://www.facebook.com/GeeskaafrikaOnline"  >Like</a></span></div></div><div class="td_social_type td-pb-margin-side td_social_twitter"><div class="td-social-box"><div class="td-sp td-sp-twitter"></div><span class="td_social_info">1,682</span><span class="td_social_info td_social_info_name">Followers</span><span class="td_social_button"><a href="https://twitter.com/GeskaAfrika"  >Follow</a></span></div></div></div></div><div class="td_block_wrap td_block_1 td_block_widget td_uid_10_61e5b392321bc_rand td-pb-border-top td_block_template_1 td-column-1"  data-td-block-uid="td_uid_10_61e5b392321bc" ><script>var block_td_uid_10_61e5b392321bc = new tdBlock();
block_td_uid_10_61e5b392321bc.id = "td_uid_10_61e5b392321bc";
block_td_uid_10_61e5b392321bc.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"20","category_ids":"","custom_title":"OPINION ","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"","header_color":"#","header_text_color":"#","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_block_widget td_uid_10_61e5b392321bc_rand","el_class":"","offset":"","css":"","tdc_css":"","tdc_css_class":"td_uid_10_61e5b392321bc_rand","tdc_css_class_style":"td_uid_10_61e5b392321bc_rand_style","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":"","block_template_id":""}';
block_td_uid_10_61e5b392321bc.td_column_number = "1";
block_td_uid_10_61e5b392321bc.block_type = "td_block_1";
block_td_uid_10_61e5b392321bc.post_count = "5";
block_td_uid_10_61e5b392321bc.found_posts = "922";
block_td_uid_10_61e5b392321bc.header_color = "#";
block_td_uid_10_61e5b392321bc.ajax_pagination_infinite_stop = "";
block_td_uid_10_61e5b392321bc.max_num_pages = "185";
tdBlocksArray.push(block_td_uid_10_61e5b392321bc);</script><div class="td-block-title-wrap"><h4 class="block-title"><span class="td-pulldown-size">OPINION </span></h4></div><div id=td_uid_10_61e5b392321bc class="td_block_inner"><div class="td-block-span12"><div class="td_module_4 td_module_wrap td-animation-stack"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.geeskaafrika.com/africa-security-briefing-and-consultations/" rel="bookmark" title="Africa: Security Briefing and Consultations"><noscript><img width="324" height="235" class="entry-thumb" src="https://www.geeskaafrika.com/wp-content/uploads/2022/01/Mahamat-Saleh-Annadif-324x235.jpg" alt="Mahamat Saleh Annadif" title="Africa: Security Briefing and Consultations"/></noscript><img width="324" height="235" class="lazyload entry-thumb" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20324%20235%22%3E%3C/svg%3E' data-src="https://www.geeskaafrika.com/wp-content/uploads/2022/01/Mahamat-Saleh-Annadif-324x235.jpg" alt="Mahamat Saleh Annadif" title="Africa: Security Briefing and Consultations"/></a></div> <a href="https://www.geeskaafrika.com/category/daily-security-briefing/" class="td-post-category">Daily Security Briefing</a></div><h3 class="entry-title td-module-title"><a href="https://www.geeskaafrika.com/africa-security-briefing-and-consultations/" rel="bookmark" title="Africa: Security Briefing and Consultations">Africa: Security Briefing and Consultations</a></h3><div class="td-module-meta-info"> <span class="td-post-author-name"><a href="https://www.geeskaafrika.com/author/geeskadmin/">geeskaadmin</a> <span>-</span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-01-11T11:03:48+00:00" >11 January 2022</time></span><div class="td-module-comments"><a href="https://www.geeskaafrika.com/africa-security-briefing-and-consultations/#respond">0</a></div></div><div class="td-excerpt"> The Security Council will hold a briefing, followed by consultations, on West Africa and the Sahel. The expected briefers are Special Representative and head...</div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.geeskaafrika.com/the-brewing-new-confrontation-in-the-horn-of-africa/" rel="bookmark" title="The Brewing New Confrontation In the Horn of Africa"><noscript><img width="100" height="70" class="entry-thumb" src="https://www.geeskaafrika.com/wp-content/uploads/2021/05/djibouti_bases-100x70.png" srcset="https://www.geeskaafrika.com/wp-content/uploads/2021/05/djibouti_bases-100x70.png 100w, https://www.geeskaafrika.com/wp-content/uploads/2021/05/djibouti_bases-218x150.png 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="The Brewing New Confrontation In the Horn of Africa"/></noscript><img width="100" height="70" class="lazyload entry-thumb" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20100%2070%22%3E%3C/svg%3E' data-src="https://www.geeskaafrika.com/wp-content/uploads/2021/05/djibouti_bases-100x70.png" data-srcset="https://www.geeskaafrika.com/wp-content/uploads/2021/05/djibouti_bases-100x70.png 100w, https://www.geeskaafrika.com/wp-content/uploads/2021/05/djibouti_bases-218x150.png 218w" data-sizes="(max-width: 100px) 100vw, 100px" alt="" title="The Brewing New Confrontation In the Horn of Africa"/></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.geeskaafrika.com/the-brewing-new-confrontation-in-the-horn-of-africa/" rel="bookmark" title="The Brewing New Confrontation In the Horn of Africa">The Brewing New Confrontation In the Horn of Africa</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-05-20T19:28:31+00:00" >20 May 2021</time></span></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.geeskaafrika.com/somalia-mr-president-please-trim-your-hair/" rel="bookmark" title="Somalia: Mr. President, Please Trim Your Hair"><noscript><img width="100" height="70" class="entry-thumb" src="https://www.geeskaafrika.com/wp-content/uploads/2021/05/farmajo_2016-100x70.jpeg" srcset="https://www.geeskaafrika.com/wp-content/uploads/2021/05/farmajo_2016-100x70.jpeg 100w, https://www.geeskaafrika.com/wp-content/uploads/2021/05/farmajo_2016-218x150.jpeg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Somalia: Mr. President, Please Trim Your Hair"/></noscript><img width="100" height="70" class="lazyload entry-thumb" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20100%2070%22%3E%3C/svg%3E' data-src="https://www.geeskaafrika.com/wp-content/uploads/2021/05/farmajo_2016-100x70.jpeg" data-srcset="https://www.geeskaafrika.com/wp-content/uploads/2021/05/farmajo_2016-100x70.jpeg 100w, https://www.geeskaafrika.com/wp-content/uploads/2021/05/farmajo_2016-218x150.jpeg 218w" data-sizes="(max-width: 100px) 100vw, 100px" alt="" title="Somalia: Mr. President, Please Trim Your Hair"/></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.geeskaafrika.com/somalia-mr-president-please-trim-your-hair/" rel="bookmark" title="Somalia: Mr. President, Please Trim Your Hair">Somalia: Mr. President, Please Trim Your Hair</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-05-20T19:11:53+00:00" >20 May 2021</time></span></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.geeskaafrika.com/ethiopias-debt-an-economic-and-political-liability/" rel="bookmark" title="Ethiopia’s debt: an economic and political liability"><noscript><img width="100" height="70" class="entry-thumb" src="https://www.geeskaafrika.com/wp-content/uploads/2021/05/70816941_660072924483894_870625643681808384_n-1-768x512-1-100x70.jpg" srcset="https://www.geeskaafrika.com/wp-content/uploads/2021/05/70816941_660072924483894_870625643681808384_n-1-768x512-1-100x70.jpg 100w, https://www.geeskaafrika.com/wp-content/uploads/2021/05/70816941_660072924483894_870625643681808384_n-1-768x512-1-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="Ethiopia’s debt: an economic and political liability" title="Ethiopia’s debt: an economic and political liability"/></noscript><img width="100" height="70" class="lazyload entry-thumb" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20100%2070%22%3E%3C/svg%3E' data-src="https://www.geeskaafrika.com/wp-content/uploads/2021/05/70816941_660072924483894_870625643681808384_n-1-768x512-1-100x70.jpg" data-srcset="https://www.geeskaafrika.com/wp-content/uploads/2021/05/70816941_660072924483894_870625643681808384_n-1-768x512-1-100x70.jpg 100w, https://www.geeskaafrika.com/wp-content/uploads/2021/05/70816941_660072924483894_870625643681808384_n-1-768x512-1-218x150.jpg 218w" data-sizes="(max-width: 100px) 100vw, 100px" alt="Ethiopia’s debt: an economic and political liability" title="Ethiopia’s debt: an economic and political liability"/></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.geeskaafrika.com/ethiopias-debt-an-economic-and-political-liability/" rel="bookmark" title="Ethiopia’s debt: an economic and political liability">Ethiopia’s debt: an economic and political liability</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-05-16T10:41:29+00:00" >16 May 2021</time></span></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.geeskaafrika.com/the-somalia-kenya-conundrum/" rel="bookmark" title="The Somalia Kenya Conundrum"><noscript><img width="100" height="70" class="entry-thumb" src="https://www.geeskaafrika.com/wp-content/uploads/2021/05/somali-flag-june-1960-1-100x70.jpg" srcset="https://www.geeskaafrika.com/wp-content/uploads/2021/05/somali-flag-june-1960-1-100x70.jpg 100w, https://www.geeskaafrika.com/wp-content/uploads/2021/05/somali-flag-june-1960-1-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="somali-flag flutters over Hargeisa 1960" title="The Somalia Kenya Conundrum"/></noscript><img width="100" height="70" class="lazyload entry-thumb" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20100%2070%22%3E%3C/svg%3E' data-src="https://www.geeskaafrika.com/wp-content/uploads/2021/05/somali-flag-june-1960-1-100x70.jpg" data-srcset="https://www.geeskaafrika.com/wp-content/uploads/2021/05/somali-flag-june-1960-1-100x70.jpg 100w, https://www.geeskaafrika.com/wp-content/uploads/2021/05/somali-flag-june-1960-1-218x150.jpg 218w" data-sizes="(max-width: 100px) 100vw, 100px" alt="somali-flag flutters over Hargeisa 1960" title="The Somalia Kenya Conundrum"/></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.geeskaafrika.com/the-somalia-kenya-conundrum/" rel="bookmark" title="The Somalia Kenya Conundrum">The Somalia Kenya Conundrum</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-05-15T16:14:16+00:00" >15 May 2021</time></span></div></div></div></div></div></div><div class="td_block_wrap td_block_1 td_block_widget td_uid_11_61e5b3923505c_rand td-pb-border-top td_block_template_1 td-column-1"  data-td-block-uid="td_uid_11_61e5b3923505c" ><script>var block_td_uid_11_61e5b3923505c = new tdBlock();
block_td_uid_11_61e5b3923505c.id = "td_uid_11_61e5b3923505c";
block_td_uid_11_61e5b3923505c.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"13","category_ids":"","custom_title":"Interview","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"","header_color":"#","header_text_color":"#","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_block_widget td_uid_11_61e5b3923505c_rand","el_class":"","offset":"","css":"","tdc_css":"","tdc_css_class":"td_uid_11_61e5b3923505c_rand","tdc_css_class_style":"td_uid_11_61e5b3923505c_rand_style","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":"","block_template_id":""}';
block_td_uid_11_61e5b3923505c.td_column_number = "1";
block_td_uid_11_61e5b3923505c.block_type = "td_block_1";
block_td_uid_11_61e5b3923505c.post_count = "5";
block_td_uid_11_61e5b3923505c.found_posts = "175";
block_td_uid_11_61e5b3923505c.header_color = "#";
block_td_uid_11_61e5b3923505c.ajax_pagination_infinite_stop = "";
block_td_uid_11_61e5b3923505c.max_num_pages = "35";
tdBlocksArray.push(block_td_uid_11_61e5b3923505c);</script><div class="td-block-title-wrap"><h4 class="block-title"><span class="td-pulldown-size">Interview</span></h4></div><div id=td_uid_11_61e5b3923505c class="td_block_inner"><div class="td-block-span12"><div class="td_module_4 td_module_wrap td-animation-stack"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.geeskaafrika.com/somaliland-vp-saylici-tests-positive-for-covid-19/" rel="bookmark" title="Somaliland VP Saylici tests positive for COVID-19"><noscript><img width="324" height="235" class="entry-thumb" src="https://www.geeskaafrika.com/wp-content/uploads/2021/03/EtpKRkqXIAA3ZcN-324x235.jpg" alt="Somaliland VP Saylici" title="Somaliland VP Saylici tests positive for COVID-19"/></noscript><img width="324" height="235" class="lazyload entry-thumb" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20324%20235%22%3E%3C/svg%3E' data-src="https://www.geeskaafrika.com/wp-content/uploads/2021/03/EtpKRkqXIAA3ZcN-324x235.jpg" alt="Somaliland VP Saylici" title="Somaliland VP Saylici tests positive for COVID-19"/></a></div> <a href="https://www.geeskaafrika.com/category/frontpage/" class="td-post-category">frontpage</a></div><h3 class="entry-title td-module-title"><a href="https://www.geeskaafrika.com/somaliland-vp-saylici-tests-positive-for-covid-19/" rel="bookmark" title="Somaliland VP Saylici tests positive for COVID-19">Somaliland VP Saylici tests positive for COVID-19</a></h3><div class="td-module-meta-info"> <span class="td-post-author-name"><a href="https://www.geeskaafrika.com/author/geeskadmin/">geeskaadmin</a> <span>-</span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-03-16T11:55:11+00:00" >16 March 2021</time></span><div class="td-module-comments"><a href="https://www.geeskaafrika.com/somaliland-vp-saylici-tests-positive-for-covid-19/#respond">0</a></div></div><div class="td-excerpt"> HARGEISA: Somaliland vice president Abdirahman Saylici has contracted COVID-19 making him the senior most government official in the break-away region to get the virus.  Saylici...</div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.geeskaafrika.com/ethiopian-diplomat-berhane-kidanemariam-resigns/" rel="bookmark" title="Ethiopian diplomat Berhane Kidanemariam resigns"><noscript><img width="100" height="70" class="entry-thumb" src="https://www.geeskaafrika.com/wp-content/uploads/2021/03/EwIvBmcXAAEKkCE-100x70.jpg" srcset="https://www.geeskaafrika.com/wp-content/uploads/2021/03/EwIvBmcXAAEKkCE-100x70.jpg 100w, https://www.geeskaafrika.com/wp-content/uploads/2021/03/EwIvBmcXAAEKkCE-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="Berhane Kidanemariam" title="Ethiopian diplomat Berhane Kidanemariam resigns"/></noscript><img width="100" height="70" class="lazyload entry-thumb" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20100%2070%22%3E%3C/svg%3E' data-src="https://www.geeskaafrika.com/wp-content/uploads/2021/03/EwIvBmcXAAEKkCE-100x70.jpg" data-srcset="https://www.geeskaafrika.com/wp-content/uploads/2021/03/EwIvBmcXAAEKkCE-100x70.jpg 100w, https://www.geeskaafrika.com/wp-content/uploads/2021/03/EwIvBmcXAAEKkCE-218x150.jpg 218w" data-sizes="(max-width: 100px) 100vw, 100px" alt="Berhane Kidanemariam" title="Ethiopian diplomat Berhane Kidanemariam resigns"/></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.geeskaafrika.com/ethiopian-diplomat-berhane-kidanemariam-resigns/" rel="bookmark" title="Ethiopian diplomat Berhane Kidanemariam resigns">Ethiopian diplomat Berhane Kidanemariam resigns</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-03-10T14:54:26+00:00" >10 March 2021</time></span></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.geeskaafrika.com/operations-to-restore-law-and-order-in-ethiopias-tigray-region/" rel="bookmark" title="Operations To Restore Law And Order In Ethiopia’s Tigray Region"><noscript><img width="100" height="70" class="entry-thumb" src="https://www.geeskaafrika.com/wp-content/uploads/2020/12/PM-Abiy-1-100x70.jpg" srcset="https://www.geeskaafrika.com/wp-content/uploads/2020/12/PM-Abiy-1-100x70.jpg 100w, https://www.geeskaafrika.com/wp-content/uploads/2020/12/PM-Abiy-1-218x150.jpg 218w, https://www.geeskaafrika.com/wp-content/uploads/2020/12/PM-Abiy-1-549x385.jpg 549w" sizes="(max-width: 100px) 100vw, 100px" alt="PM-Abiy-" title="Operations To Restore Law And Order In Ethiopia’s Tigray Region"/></noscript><img width="100" height="70" class="lazyload entry-thumb" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20100%2070%22%3E%3C/svg%3E' data-src="https://www.geeskaafrika.com/wp-content/uploads/2020/12/PM-Abiy-1-100x70.jpg" data-srcset="https://www.geeskaafrika.com/wp-content/uploads/2020/12/PM-Abiy-1-100x70.jpg 100w, https://www.geeskaafrika.com/wp-content/uploads/2020/12/PM-Abiy-1-218x150.jpg 218w, https://www.geeskaafrika.com/wp-content/uploads/2020/12/PM-Abiy-1-549x385.jpg 549w" data-sizes="(max-width: 100px) 100vw, 100px" alt="PM-Abiy-" title="Operations To Restore Law And Order In Ethiopia’s Tigray Region"/></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.geeskaafrika.com/operations-to-restore-law-and-order-in-ethiopias-tigray-region/" rel="bookmark" title="Operations To Restore Law And Order In Ethiopia’s Tigray Region">Operations To Restore Law And Order In Ethiopia’s Tigray Region</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-12-24T04:05:48+00:00" >24 December 2020</time></span></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.geeskaafrika.com/ethiopia-interview-with-prof-mohamed-hassan-horn-of-africa-and-beyond/" rel="bookmark" title="Ethiopia: Prof. Mohamed Hassan, Horn of Africa and Beyond (Interview)"><noscript><img width="100" height="70" class="entry-thumb" src="https://www.geeskaafrika.com/wp-content/uploads/2020/12/Prof._Mohamed_Hassan-100x70.jpg" srcset="https://www.geeskaafrika.com/wp-content/uploads/2020/12/Prof._Mohamed_Hassan-100x70.jpg 100w, https://www.geeskaafrika.com/wp-content/uploads/2020/12/Prof._Mohamed_Hassan-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Ethiopia: Prof. Mohamed Hassan, Horn of Africa and Beyond (Interview)"/></noscript><img width="100" height="70" class="lazyload entry-thumb" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20100%2070%22%3E%3C/svg%3E' data-src="https://www.geeskaafrika.com/wp-content/uploads/2020/12/Prof._Mohamed_Hassan-100x70.jpg" data-srcset="https://www.geeskaafrika.com/wp-content/uploads/2020/12/Prof._Mohamed_Hassan-100x70.jpg 100w, https://www.geeskaafrika.com/wp-content/uploads/2020/12/Prof._Mohamed_Hassan-218x150.jpg 218w" data-sizes="(max-width: 100px) 100vw, 100px" alt="" title="Ethiopia: Prof. Mohamed Hassan, Horn of Africa and Beyond (Interview)"/></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.geeskaafrika.com/ethiopia-interview-with-prof-mohamed-hassan-horn-of-africa-and-beyond/" rel="bookmark" title="Ethiopia: Prof. Mohamed Hassan, Horn of Africa and Beyond (Interview)">Ethiopia: Prof. Mohamed Hassan, Horn of Africa and Beyond (Interview)</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-12-16T23:57:03+00:00" >16 December 2020</time></span></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.geeskaafrika.com/ethiopia-prime-minister-abiy-ahmeds-first-interview-to-western-news-media/" rel="bookmark" title="Ethiopia: Prime Minister Abiy Ahmed&#8217;s First Interview to Western News Media"><noscript><img width="100" height="70" class="entry-thumb" src="https://www.geeskaafrika.com/wp-content/uploads/2020/12/voa_abey-100x70.jpg" srcset="https://www.geeskaafrika.com/wp-content/uploads/2020/12/voa_abey-100x70.jpg 100w, https://www.geeskaafrika.com/wp-content/uploads/2020/12/voa_abey-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Ethiopia: Prime Minister Abiy Ahmed&#8217;s First Interview to Western News Media"/></noscript><img width="100" height="70" class="lazyload entry-thumb" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20100%2070%22%3E%3C/svg%3E' data-src="https://www.geeskaafrika.com/wp-content/uploads/2020/12/voa_abey-100x70.jpg" data-srcset="https://www.geeskaafrika.com/wp-content/uploads/2020/12/voa_abey-100x70.jpg 100w, https://www.geeskaafrika.com/wp-content/uploads/2020/12/voa_abey-218x150.jpg 218w" data-sizes="(max-width: 100px) 100vw, 100px" alt="" title="Ethiopia: Prime Minister Abiy Ahmed&#8217;s First Interview to Western News Media"/></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.geeskaafrika.com/ethiopia-prime-minister-abiy-ahmeds-first-interview-to-western-news-media/" rel="bookmark" title="Ethiopia: Prime Minister Abiy Ahmed&#8217;s First Interview to Western News Media">Ethiopia: Prime Minister Abiy Ahmed&#8217;s First Interview to Western News Media</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-12-06T00:54:32+00:00" >6 December 2020</time></span></div></div></div></div></div></div><div class="td_block_wrap td_block_1 td_block_widget td_uid_12_61e5b39236f29_rand td-pb-border-top td_block_template_1 td-column-1"  data-td-block-uid="td_uid_12_61e5b39236f29" ><script>var block_td_uid_12_61e5b39236f29 = new tdBlock();
block_td_uid_12_61e5b39236f29.id = "td_uid_12_61e5b39236f29";
block_td_uid_12_61e5b39236f29.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"25","category_ids":"","custom_title":"SPORTS","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"","header_color":"#","header_text_color":"#","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_block_widget td_uid_12_61e5b39236f29_rand","el_class":"","offset":"","css":"","tdc_css":"","tdc_css_class":"td_uid_12_61e5b39236f29_rand","tdc_css_class_style":"td_uid_12_61e5b39236f29_rand_style","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":"","block_template_id":""}';
block_td_uid_12_61e5b39236f29.td_column_number = "1";
block_td_uid_12_61e5b39236f29.block_type = "td_block_1";
block_td_uid_12_61e5b39236f29.post_count = "5";
block_td_uid_12_61e5b39236f29.found_posts = "184";
block_td_uid_12_61e5b39236f29.header_color = "#";
block_td_uid_12_61e5b39236f29.ajax_pagination_infinite_stop = "";
block_td_uid_12_61e5b39236f29.max_num_pages = "37";
tdBlocksArray.push(block_td_uid_12_61e5b39236f29);</script><div class="td-block-title-wrap"><h4 class="block-title"><span class="td-pulldown-size">SPORTS</span></h4></div><div id=td_uid_12_61e5b39236f29 class="td_block_inner"><div class="td-block-span12"><div class="td_module_4 td_module_wrap td-animation-stack"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.geeskaafrika.com/amen-mma-fighters-back-ufc-legend-khabib-nurmagomedov-after-he-asks-his-millions-of-fans-to-pray-for-oppressed-palestinians/" rel="bookmark" title="‘Amen’: MMA fighters back UFC legend Khabib Nurmagomedov after he asks his millions of fans to pray for ‘oppressed Palestinians’"><noscript><img width="324" height="235" class="entry-thumb" src="https://www.geeskaafrika.com/wp-content/uploads/2021/05/60a0062f2030270b9b287294-324x235.jpg" alt="UFC legend Khabib Nurmagomedov" title="‘Amen’: MMA fighters back UFC legend Khabib Nurmagomedov after he asks his millions of fans to pray for ‘oppressed Palestinians’"/></noscript><img width="324" height="235" class="lazyload entry-thumb" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20324%20235%22%3E%3C/svg%3E' data-src="https://www.geeskaafrika.com/wp-content/uploads/2021/05/60a0062f2030270b9b287294-324x235.jpg" alt="UFC legend Khabib Nurmagomedov" title="‘Amen’: MMA fighters back UFC legend Khabib Nurmagomedov after he asks his millions of fans to pray for ‘oppressed Palestinians’"/></a></div> <a href="https://www.geeskaafrika.com/category/frontpage/" class="td-post-category">frontpage</a></div><h3 class="entry-title td-module-title"><a href="https://www.geeskaafrika.com/amen-mma-fighters-back-ufc-legend-khabib-nurmagomedov-after-he-asks-his-millions-of-fans-to-pray-for-oppressed-palestinians/" rel="bookmark" title="‘Amen’: MMA fighters back UFC legend Khabib Nurmagomedov after he asks his millions of fans to pray for ‘oppressed Palestinians’">‘Amen’: MMA fighters back UFC legend Khabib Nurmagomedov after he asks...</a></h3><div class="td-module-meta-info"> <span class="td-post-author-name"><a href="https://www.geeskaafrika.com/author/geeskadmin/">geeskaadmin</a> <span>-</span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-05-16T08:07:25+00:00" >16 May 2021</time></span><div class="td-module-comments"><a href="https://www.geeskaafrika.com/amen-mma-fighters-back-ufc-legend-khabib-nurmagomedov-after-he-asks-his-millions-of-fans-to-pray-for-oppressed-palestinians/#respond">0</a></div></div><div class="td-excerpt"> UFC icon Khabib Nurmagomedov has been inundated with praise after asking his fans to pray during the ongoing conflict between Israel and Palestine, sharing...</div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.geeskaafrika.com/ethiopia-genzebe-dibaba-wins-valencia-half-marathon/" rel="bookmark" title="Ethiopia: Genzebe Dibaba Wins Valencia Half-Marathon"><noscript><img width="100" height="70" class="entry-thumb" src="https://www.geeskaafrika.com/wp-content/uploads/2020/12/Genzebe-Dibaba-750x430-1-100x70.jpg" srcset="https://www.geeskaafrika.com/wp-content/uploads/2020/12/Genzebe-Dibaba-750x430-1-100x70.jpg 100w, https://www.geeskaafrika.com/wp-content/uploads/2020/12/Genzebe-Dibaba-750x430-1-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="Ethiopia Genzebe-Dibaba" title="Ethiopia: Genzebe Dibaba Wins Valencia Half-Marathon"/></noscript><img width="100" height="70" class="lazyload entry-thumb" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20100%2070%22%3E%3C/svg%3E' data-src="https://www.geeskaafrika.com/wp-content/uploads/2020/12/Genzebe-Dibaba-750x430-1-100x70.jpg" data-srcset="https://www.geeskaafrika.com/wp-content/uploads/2020/12/Genzebe-Dibaba-750x430-1-100x70.jpg 100w, https://www.geeskaafrika.com/wp-content/uploads/2020/12/Genzebe-Dibaba-750x430-1-218x150.jpg 218w" data-sizes="(max-width: 100px) 100vw, 100px" alt="Ethiopia Genzebe-Dibaba" title="Ethiopia: Genzebe Dibaba Wins Valencia Half-Marathon"/></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.geeskaafrika.com/ethiopia-genzebe-dibaba-wins-valencia-half-marathon/" rel="bookmark" title="Ethiopia: Genzebe Dibaba Wins Valencia Half-Marathon">Ethiopia: Genzebe Dibaba Wins Valencia Half-Marathon</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-12-06T05:50:39+00:00" >6 December 2020</time></span></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.geeskaafrika.com/ethiopian-born-adonya-wondwosen-signs-for-manchester-united/" rel="bookmark" title="Ethiopian- Born Adonya Wondwosen Signs For Manchester United"><noscript><img width="100" height="70" class="entry-thumb" src="https://www.geeskaafrika.com/wp-content/uploads/2020/10/Adoniaaaaaaaaaaaa-750x430-1-100x70.jpg" srcset="https://www.geeskaafrika.com/wp-content/uploads/2020/10/Adoniaaaaaaaaaaaa-750x430-1-100x70.jpg 100w, https://www.geeskaafrika.com/wp-content/uploads/2020/10/Adoniaaaaaaaaaaaa-750x430-1-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="Ethiopia Manchester United" title="Ethiopian- Born Adonya Wondwosen Signs For Manchester United"/></noscript><img width="100" height="70" class="lazyload entry-thumb" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20100%2070%22%3E%3C/svg%3E' data-src="https://www.geeskaafrika.com/wp-content/uploads/2020/10/Adoniaaaaaaaaaaaa-750x430-1-100x70.jpg" data-srcset="https://www.geeskaafrika.com/wp-content/uploads/2020/10/Adoniaaaaaaaaaaaa-750x430-1-100x70.jpg 100w, https://www.geeskaafrika.com/wp-content/uploads/2020/10/Adoniaaaaaaaaaaaa-750x430-1-218x150.jpg 218w" data-sizes="(max-width: 100px) 100vw, 100px" alt="Ethiopia Manchester United" title="Ethiopian- Born Adonya Wondwosen Signs For Manchester United"/></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.geeskaafrika.com/ethiopian-born-adonya-wondwosen-signs-for-manchester-united/" rel="bookmark" title="Ethiopian- Born Adonya Wondwosen Signs For Manchester United">Ethiopian- Born Adonya Wondwosen Signs For Manchester United</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-10-14T03:58:01+00:00" >14 October 2020</time></span></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.geeskaafrika.com/30958/" rel="bookmark" title="Ethiopia’s Letesenbet Breaks 5,000m World Record"><noscript><img width="100" height="70" class="entry-thumb" src="https://www.geeskaafrika.com/wp-content/uploads/2020/10/3459647-000_1KS3EV-100x70.jpg" srcset="https://www.geeskaafrika.com/wp-content/uploads/2020/10/3459647-000_1KS3EV-100x70.jpg 100w, https://www.geeskaafrika.com/wp-content/uploads/2020/10/3459647-000_1KS3EV-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="Ethiopia’s Letesenbet Breaks 5,000m World Record" title="Ethiopia’s Letesenbet Breaks 5,000m World Record"/></noscript><img width="100" height="70" class="lazyload entry-thumb" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20100%2070%22%3E%3C/svg%3E' data-src="https://www.geeskaafrika.com/wp-content/uploads/2020/10/3459647-000_1KS3EV-100x70.jpg" data-srcset="https://www.geeskaafrika.com/wp-content/uploads/2020/10/3459647-000_1KS3EV-100x70.jpg 100w, https://www.geeskaafrika.com/wp-content/uploads/2020/10/3459647-000_1KS3EV-218x150.jpg 218w" data-sizes="(max-width: 100px) 100vw, 100px" alt="Ethiopia’s Letesenbet Breaks 5,000m World Record" title="Ethiopia’s Letesenbet Breaks 5,000m World Record"/></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.geeskaafrika.com/30958/" rel="bookmark" title="Ethiopia’s Letesenbet Breaks 5,000m World Record">Ethiopia’s Letesenbet Breaks 5,000m World Record</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-10-08T02:29:45+00:00" >8 October 2020</time></span></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.geeskaafrika.com/30929/" rel="bookmark" title="Ethiopia: BREAKING Supersport acquired exclusive rights to broadcast Ethiopian Premier League"><noscript><img width="100" height="70" class="entry-thumb" src="https://www.geeskaafrika.com/wp-content/uploads/2020/10/NCS_SuperSport-Studio-6_0001-100x70.jpg" srcset="https://www.geeskaafrika.com/wp-content/uploads/2020/10/NCS_SuperSport-Studio-6_0001-100x70.jpg 100w, https://www.geeskaafrika.com/wp-content/uploads/2020/10/NCS_SuperSport-Studio-6_0001-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="Ethiopia SUPERSPORT" title="Ethiopia: BREAKING Supersport acquired exclusive rights to broadcast Ethiopian Premier League"/></noscript><img width="100" height="70" class="lazyload entry-thumb" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20100%2070%22%3E%3C/svg%3E' data-src="https://www.geeskaafrika.com/wp-content/uploads/2020/10/NCS_SuperSport-Studio-6_0001-100x70.jpg" data-srcset="https://www.geeskaafrika.com/wp-content/uploads/2020/10/NCS_SuperSport-Studio-6_0001-100x70.jpg 100w, https://www.geeskaafrika.com/wp-content/uploads/2020/10/NCS_SuperSport-Studio-6_0001-218x150.jpg 218w" data-sizes="(max-width: 100px) 100vw, 100px" alt="Ethiopia SUPERSPORT" title="Ethiopia: BREAKING Supersport acquired exclusive rights to broadcast Ethiopian Premier League"/></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.geeskaafrika.com/30929/" rel="bookmark" title="Ethiopia: BREAKING Supersport acquired exclusive rights to broadcast Ethiopian Premier League">Ethiopia: BREAKING Supersport acquired exclusive rights to broadcast Ethiopian Premier League</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-10-07T11:50:25+00:00" >7 October 2020</time></span></div></div></div></div></div></div></div></div></div></div></article><div class="td-footer-wrapper td-container-wrap td-footer-template-4 "><div class="td-container"><div class="td-pb-row"><div class="td-pb-span12"></div></div><div class="td-pb-row"><div class="td-pb-span12"><div class="td-footer-info"><div class="footer-logo-wrap"><a href="https://www.geeskaafrika.com/"><noscript><img class="td-retina-data" src="https://geeskaafrika.com/wp-content/uploads/2016/01/geeska-footer-300x121.png" data-retina="https://geeskaafrika.com/wp-content/uploads/2016/01/geeska-footer-300x121.png" alt="" title="" width="" /></noscript><img class="lazyload td-retina-data" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20210%20140%22%3E%3C/svg%3E' data-src="https://geeskaafrika.com/wp-content/uploads/2016/01/geeska-footer-300x121.png" data-retina="https://geeskaafrika.com/wp-content/uploads/2016/01/geeska-footer-300x121.png" alt="" title="" width="" /></a></div><div class="footer-text-wrap">Geeska Afrika Online (1985) a voice of East Africa.The Oldest Independent Free Press in the region. Geeska Afrika original reporting by our award-winning journalists.  producing and distributing 50 news and information items daily from over 100 African news organizations . To address comments or complaints, please Contact us. HAN@Geeskaafrika.com<div class="footer-email-wrap">Contact us: <a href="mailto:HAN@Geeskaafrika.com">HAN@Geeskaafrika.com</a></div></div><div class="footer-social-wrap td-social-style-2"> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.facebook.com/GeeskaAfrikaOnline" title="Facebook"> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://twitter.com/GeskaAfrika" title="Twitter"> <i class="td-icon-font td-icon-twitter"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="#" title="Vimeo"> <i class="td-icon-font td-icon-vimeo"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="#" title="VKontakte"> <i class="td-icon-font td-icon-vk"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="#" title="Youtube"> <i class="td-icon-font td-icon-youtube"></i> </a> </span></div></div></div></div></div></div><div class="td-sub-footer-container td-container-wrap "><div class="td-container"><div class="td-pb-row"><div class="td-pb-span td-sub-footer-menu"></div><div class="td-pb-span td-sub-footer-copy"> &copy; Copyright © 2020 - Geeskaafrika</div></div></div></div></div> <noscript><img alt='css.php' src="https://www.geeskaafrika.com/wp-content/plugins/cookies-for-comments/css.php?k=e038a462dfaa5c51e3f17af79baac9dd&amp;o=i&amp;t=1644371504" width='1' height='1' /></noscript><img class="lazyload" alt='css.php' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%201%201%22%3E%3C/svg%3E' data-src="https://www.geeskaafrika.com/wp-content/plugins/cookies-for-comments/css.php?k=e038a462dfaa5c51e3f17af79baac9dd&amp;o=i&amp;t=1644371504" width='1' height='1' />  <script type="text/javascript">function downloadJSAtOnload() {
var element = document.createElement("script");
element.src = "//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js";
document.body.appendChild(element);
}
if (window.addEventListener)
window.addEventListener("load", downloadJSAtOnload, false);
else if (window.attachEvent)
window.attachEvent("onload", downloadJSAtOnload);
else window.onload = downloadJSAtOnload;</script><noscript><style>.lazyload{display:none;}</style></noscript><script data-noptimize="1">window.lazySizesConfig=window.lazySizesConfig||{};window.lazySizesConfig.loadMode=1;</script><script async data-noptimize="1" src='https://www.geeskaafrika.com/wp-content/plugins/autoptimize/classes/external/js/lazysizes.min.js?ao_version=2.9.5'></script> <div id="ss-floating-bar" class="ss-left-sidebar ss-large-icons ss-hide-on-mobile ss-with-spacing ss-rectangle-icons"><ul class="ss-social-icons-container"><li class=""> <a href="#" data-ss-ss-link="https://www.facebook.com/sharer.php?t=Somaliland%20to%20Join%20British%20Commonwealth%20Again%3A1954&#038;u=https%3A%2F%2Fwww.geeskaafrika.com%2Fsomaliland-to-join-british-commonwealth-again1954%2F" class="ss-facebook-color" rel="nofollow noopener" data-ss-ss-network-id="facebook" data-ss-ss-post-id="33919" data-ss-ss-location="sidebar" data-ss-ss-permalink="https://www.geeskaafrika.com/somaliland-to-join-british-commonwealth-again1954/" data-ss-ss-type="share" data-has-api="true"> <span class="ss-share-network-content"> <i class="ss-network-icon"><svg class="ss-svg-icon" aria-hidden="true" role="img" focusable="false" width="32" height="32" viewBox="0 0 32 32" xmlns="http://www.w3.org/2000/svg"><path d="M32 16.098C32 7.208 24.837 0 16 0S0 7.207 0 16.098C0 24.133 5.851 30.792 13.5 32V20.751H9.437v-4.653H13.5V12.55c0-4.034 2.389-6.263 6.043-6.263 1.751 0 3.582.315 3.582.315v3.961h-2.018c-1.987 0-2.607 1.241-2.607 2.514v3.02h4.438l-.71 4.653H18.5V32C26.149 30.792 32 24.133 32 16.098z" /></svg></i> <span class="ss-network-count"> 0 </span> </span> </a> <span class="ss-share-network-tooltip">Facebook</span></li><li class=""> <a href="#" data-ss-ss-link="https://twitter.com/intent/tweet?text=Somaliland+to+Join+British+Commonwealth+Again%3A1954&#038;url=https%3A%2F%2Fwww.geeskaafrika.com%2Fsomaliland-to-join-british-commonwealth-again1954%2F" class="ss-twitter-color" rel="nofollow noopener" data-ss-ss-network-id="twitter" data-ss-ss-post-id="33919" data-ss-ss-location="sidebar" data-ss-ss-permalink="https://www.geeskaafrika.com/somaliland-to-join-british-commonwealth-again1954/" data-ss-ss-type="share"> <span class="ss-share-network-content"> <i class="ss-network-icon"><svg class="ss-svg-icon" aria-hidden="true" role="img" focusable="false" width="32" height="32" viewBox="0 0 32 32" xmlns="http://www.w3.org/2000/svg"><path d="M28.75 9.5c0 0.25 0 0.563 0 0.813 0 8.688-6.625 18.688-18.688 18.688-3.688 0-7.188-1.063-10.063-2.938 0.5 0.063 1.063 0.063 1.563 0.063 3.063 0 5.938-1 8.188-2.813-2.875 0-5.313-1.938-6.188-4.563 0.438 0.125 0.813 0.125 1.25 0.125 0.625 0 1.188-0.063 1.75-0.188-3-0.625-5.25-3.313-5.25-6.438 0-0.063 0-0.063 0-0.125 0.875 0.5 1.875 0.813 2.938 0.813-1.75-1.125-2.938-3.188-2.938-5.438 0-1.188 0.375-2.313 0.938-3.313 3.188 4 8.063 6.625 13.5 6.875-0.125-0.5-0.188-1-0.188-1.5 0-3.625 2.938-6.563 6.563-6.563 1.938 0 3.625 0.813 4.813 2.063 1.5-0.313 2.938-0.813 4.188-1.563-0.5 1.5-1.563 2.813-2.875 3.625 1.313-0.188 2.563-0.5 3.75-1.063-0.875 1.313-2 2.5-3.25 3.438z"></path></svg></i> </span> </a> <span class="ss-share-network-tooltip">Twitter</span></li><li class=""> <a href="#" data-ss-ss-link="https://www.linkedin.com/shareArticle?title=Somaliland%20to%20Join%20British%20Commonwealth%20Again%3A1954&#038;url=https%3A%2F%2Fwww.geeskaafrika.com%2Fsomaliland-to-join-british-commonwealth-again1954%2F&#038;mini=true" class="ss-linkedin-color" rel="nofollow noopener" data-ss-ss-network-id="linkedin" data-ss-ss-post-id="33919" data-ss-ss-location="sidebar" data-ss-ss-permalink="https://www.geeskaafrika.com/somaliland-to-join-british-commonwealth-again1954/" data-ss-ss-type="share"> <span class="ss-share-network-content"> <i class="ss-network-icon"><svg class="ss-svg-icon" aria-hidden="true" role="img" focusable="false" width="32" height="32" viewBox="0 0 32 32" xmlns="http://www.w3.org/2000/svg"><path fill-rule="evenodd" d="M29.632 0C30.939 0 32 1.032 32 2.307v27.384C32 30.966 30.939 32 29.632 32H2.36C1.058 32 0 30.966 0 29.69V2.308C0 1.032 1.058 0 2.36 0h27.272zM9.149 11.638h-4.77V27h4.77V11.638zm12.133-.382c-2.318 0-3.874 1.273-4.509 2.48h-.066v-2.098H12.14V27h4.76v-7.599c0-2.004.378-3.946 2.858-3.946 2.447 0 2.475 2.29 2.475 4.072V27H27v-8.423c0-4.138-.893-7.32-5.718-7.32v-.001zM6.764 4A2.766 2.766 0 004 6.769a2.765 2.765 0 105.528 0A2.767 2.767 0 006.765 4h-.001z" /></svg></i> </span> </a> <span class="ss-share-network-tooltip">LinkedIn</span></li><li class=""> <a href="#" data-ss-ss-link="mailto:?body=https%3A%2F%2Fwww.geeskaafrika.com%2Fsomaliland-to-join-british-commonwealth-again1954%2F&#038;subject=Somaliland%20to%20Join%20British%20Commonwealth%20Again%3A1954" class="ss-envelope-color" rel="nofollow noopener" data-ss-ss-network-id="envelope" data-ss-ss-post-id="33919" data-ss-ss-location="sidebar" data-ss-ss-permalink="https://www.geeskaafrika.com/somaliland-to-join-british-commonwealth-again1954/" data-ss-ss-type="share"> <span class="ss-share-network-content"> <i class="ss-network-icon"><svg class="ss-svg-icon" aria-hidden="true" role="img" focusable="false" width="32" height="32" viewBox="0 0 32 32" xmlns="http://www.w3.org/2000/svg"><path d="M32 12.964v14.179c0 1.571-1.286 2.857-2.857 2.857h-26.286c-1.571 0-2.857-1.286-2.857-2.857v-14.179c0.536 0.589 1.143 1.107 1.804 1.554 2.964 2.018 5.964 4.036 8.875 6.161 1.5 1.107 3.357 2.464 5.304 2.464h0.036c1.946 0 3.804-1.357 5.304-2.464 2.911-2.107 5.911-4.143 8.893-6.161 0.643-0.446 1.25-0.964 1.786-1.554zM32 7.714c0 2-1.482 3.804-3.054 4.893-2.786 1.929-5.589 3.857-8.357 5.804-1.161 0.804-3.125 2.446-4.571 2.446h-0.036c-1.446 0-3.411-1.643-4.571-2.446-2.768-1.946-5.571-3.875-8.339-5.804-1.268-0.857-3.071-2.875-3.071-4.5 0-1.75 0.946-3.25 2.857-3.25h26.286c1.554 0 2.857 1.286 2.857 2.857z"></path></svg></i> </span> </a> <span class="ss-share-network-tooltip">Email</span></li><li class=""> <a href="#" data-ss-ss-link="https://www.geeskaafrika.com/somaliland-to-join-british-commonwealth-again1954/" class="ss-copy-color" rel="nofollow noopener" data-ss-ss-network-id="copy" data-ss-ss-post-id="33919" data-ss-ss-location="sidebar" data-ss-ss-permalink="https://www.geeskaafrika.com/somaliland-to-join-british-commonwealth-again1954/" data-ss-ss-type="share"> <span class="ss-share-network-content"> <i class="ss-network-icon"><svg class="ss-svg-icon" aria-hidden="true" role="img" focusable="false" width="32" height="32" viewBox="0 0 32 32" xmlns="http://www.w3.org/2000/svg"><path d="M25.313 28v-18.688h-14.625v18.688h14.625zM25.313 6.688c1.438 0 2.688 1.188 2.688 2.625v18.688c0 1.438-1.25 2.688-2.688 2.688h-14.625c-1.438 0-2.688-1.25-2.688-2.688v-18.688c0-1.438 1.25-2.625 2.688-2.625h14.625zM21.313 1.313v2.688h-16v18.688h-2.625v-18.688c0-1.438 1.188-2.688 2.625-2.688h16z"></path></svg></i> </span> </a> <span class="ss-share-network-tooltip">Copy Link</span></li><li> <a href="#" class="ss-share-all ss-shareall-color" rel="nofollow noopener"> <span class="ss-share-network-content"> <i class="ss-network-icon"><svg class="ss-svg-icon" aria-hidden="true" role="img" focusable="false" width="32" height="32" viewBox="0 0 32 32" xmlns="http://www.w3.org/2000/svg"><path d="M25.333 15.333h-8v-8c0-0.733-0.6-1.333-1.333-1.333s-1.333 0.6-1.333 1.333v8h-8c-0.733 0-1.333 0.6-1.333 1.333s0.6 1.333 1.333 1.333h8v8c0 0.733 0.6 1.333 1.333 1.333s1.333-0.6 1.333-1.333v-8h8c0.733 0 1.333-0.6 1.333-1.333s-0.6-1.333-1.333-1.333z"></path></svg></i> </span> </a> <span class="ss-share-network-tooltip">More Networks</span></li></ul> <span class="ss-hide-floating-bar"> <svg xmlns="http://www.w3.org/2000/svg" width="13" height="13" viewBox="0 0 370.814 370.814"><path d="M292.92 24.848L268.781 0 77.895 185.401l190.886 185.413 24.139-24.853-165.282-160.56" /></svg> </span></div> <script type='text/javascript' id='socialsnap-js-js-extra'>var socialsnap_script = {"ajaxurl":"https:\/\/www.geeskaafrika.com\/wp-admin\/admin-ajax.php","on_media_width":"250","on_media_height":"250","nonce":"8502dee361","post_id":"33919"};</script> <script>(function (basket) {basket.require({ url: "https://www.geeskaafrika.com/wp-content/plugins/socialsnap/assets/js/socialsnap.js", key: "socialsnap-js"});})(basket);</script><script>(function (basket) {basket.require({ url: "https://www.geeskaafrika.com/wp-content/themes/Newspaper/js/tagdiv_theme.min.js", key: "td-site-min"});})(basket);</script><script>(function (basket) {basket.require({ url: "https://www.geeskaafrika.com/wp-includes/js/comment-reply.min.js", key: "comment-reply"});})(basket);</script><script>(function (basket) {basket.require({ url: "https://www.geeskaafrika.com/wp-includes/js/wp-embed.min.js", key: "wp-embed"});})(basket);</script> <div id="ss-all-networks-popup" class="ss-popup-overlay" data-nonce="65ddfbf19a"><div class="ss-popup"><div class="ss-popup-heading"> <span>Share via</span> <a href="#" class="ss-close-modal" rel="nofollow noopener"> <svg class="ss-svg-icon" aria-hidden="true" role="img" focusable="false" width="32" height="32" viewBox="0 0 32 32" xmlns="http://www.w3.org/2000/svg"><path d="M17.883 16.667l7.058-7.058c0.517-0.517 0.517-1.367 0-1.883s-1.367-0.517-1.883 0l-7.058 7.058-7.058-7.058c-0.517-0.517-1.367-0.517-1.883 0s-0.517 1.367 0 1.883l7.058 7.058-7.058 7.058c-0.517 0.517-0.517 1.367 0 1.883 0.258 0.258 0.6 0.392 0.942 0.392s0.683-0.133 0.942-0.392l7.058-7.058 7.058 7.058c0.258 0.258 0.6 0.392 0.942 0.392s0.683-0.133 0.942-0.392c0.517-0.517 0.517-1.367 0-1.883l-7.058-7.058z"></path></svg> </a></div><div class="ss-popup-content"><div class="ss-popup-networks ss-clearfix"><div class="ss-popup-network ss-popup-facebook"> <a href="#" data-ss-ss-link="https://www.facebook.com/sharer.php?t=Somaliland%20to%20Join%20British%20Commonwealth%20Again%3A1954&#038;u=https%3A%2F%2Fwww.geeskaafrika.com%2Fsomaliland-to-join-british-commonwealth-again1954%2F" data-id="facebook" class="ss-facebook-color" data-ss-ss-network-id="facebook" data-ss-ss-post-id="33919" data-ss-ss-location="popup" data-ss-ss-permalink="https://www.geeskaafrika.com/somaliland-to-join-british-commonwealth-again1954/" data-ss-ss-type="share" data-has-api="true" rel="nofollow noopener"> <span><svg class="ss-svg-icon" aria-hidden="true" role="img" focusable="false" width="32" height="32" viewBox="0 0 32 32" xmlns="http://www.w3.org/2000/svg"><path d="M32 16.098C32 7.208 24.837 0 16 0S0 7.207 0 16.098C0 24.133 5.851 30.792 13.5 32V20.751H9.437v-4.653H13.5V12.55c0-4.034 2.389-6.263 6.043-6.263 1.751 0 3.582.315 3.582.315v3.961h-2.018c-1.987 0-2.607 1.241-2.607 2.514v3.02h4.438l-.71 4.653H18.5V32C26.149 30.792 32 24.133 32 16.098z" /></svg></span> <span>Facebook</span> </a></div><div class="ss-popup-network ss-popup-twitter"> <a href="#" data-ss-ss-link="https://twitter.com/intent/tweet?text=Somaliland+to+Join+British+Commonwealth+Again%3A1954&#038;url=https%3A%2F%2Fwww.geeskaafrika.com%2Fsomaliland-to-join-british-commonwealth-again1954%2F" data-id="twitter" class="ss-twitter-color" data-ss-ss-network-id="twitter" data-ss-ss-post-id="33919" data-ss-ss-location="popup" data-ss-ss-permalink="https://www.geeskaafrika.com/somaliland-to-join-british-commonwealth-again1954/" data-ss-ss-type="share" rel="nofollow noopener"> <span><svg class="ss-svg-icon" aria-hidden="true" role="img" focusable="false" width="32" height="32" viewBox="0 0 32 32" xmlns="http://www.w3.org/2000/svg"><path d="M28.75 9.5c0 0.25 0 0.563 0 0.813 0 8.688-6.625 18.688-18.688 18.688-3.688 0-7.188-1.063-10.063-2.938 0.5 0.063 1.063 0.063 1.563 0.063 3.063 0 5.938-1 8.188-2.813-2.875 0-5.313-1.938-6.188-4.563 0.438 0.125 0.813 0.125 1.25 0.125 0.625 0 1.188-0.063 1.75-0.188-3-0.625-5.25-3.313-5.25-6.438 0-0.063 0-0.063 0-0.125 0.875 0.5 1.875 0.813 2.938 0.813-1.75-1.125-2.938-3.188-2.938-5.438 0-1.188 0.375-2.313 0.938-3.313 3.188 4 8.063 6.625 13.5 6.875-0.125-0.5-0.188-1-0.188-1.5 0-3.625 2.938-6.563 6.563-6.563 1.938 0 3.625 0.813 4.813 2.063 1.5-0.313 2.938-0.813 4.188-1.563-0.5 1.5-1.563 2.813-2.875 3.625 1.313-0.188 2.563-0.5 3.75-1.063-0.875 1.313-2 2.5-3.25 3.438z"></path></svg></span> <span>Twitter</span> </a></div><div class="ss-popup-network ss-popup-linkedin"> <a href="#" data-ss-ss-link="https://www.linkedin.com/shareArticle?title=Somaliland%20to%20Join%20British%20Commonwealth%20Again%3A1954&#038;url=https%3A%2F%2Fwww.geeskaafrika.com%2Fsomaliland-to-join-british-commonwealth-again1954%2F&#038;mini=true" data-id="linkedin" class="ss-linkedin-color" data-ss-ss-network-id="linkedin" data-ss-ss-post-id="33919" data-ss-ss-location="popup" data-ss-ss-permalink="https://www.geeskaafrika.com/somaliland-to-join-british-commonwealth-again1954/" data-ss-ss-type="share" rel="nofollow noopener"> <span><svg class="ss-svg-icon" aria-hidden="true" role="img" focusable="false" width="32" height="32" viewBox="0 0 32 32" xmlns="http://www.w3.org/2000/svg"><path fill-rule="evenodd" d="M29.632 0C30.939 0 32 1.032 32 2.307v27.384C32 30.966 30.939 32 29.632 32H2.36C1.058 32 0 30.966 0 29.69V2.308C0 1.032 1.058 0 2.36 0h27.272zM9.149 11.638h-4.77V27h4.77V11.638zm12.133-.382c-2.318 0-3.874 1.273-4.509 2.48h-.066v-2.098H12.14V27h4.76v-7.599c0-2.004.378-3.946 2.858-3.946 2.447 0 2.475 2.29 2.475 4.072V27H27v-8.423c0-4.138-.893-7.32-5.718-7.32v-.001zM6.764 4A2.766 2.766 0 004 6.769a2.765 2.765 0 105.528 0A2.767 2.767 0 006.765 4h-.001z" /></svg></span> <span>LinkedIn</span> </a></div><div class="ss-popup-network ss-popup-mix"> <a href="#" data-ss-ss-link="https://mix.com/add?url=https%3A%2F%2Fwww.geeskaafrika.com%2Fsomaliland-to-join-british-commonwealth-again1954%2F" data-id="mix" class="ss-mix-color" data-ss-ss-network-id="mix" data-ss-ss-post-id="33919" data-ss-ss-location="popup" data-ss-ss-permalink="https://www.geeskaafrika.com/somaliland-to-join-british-commonwealth-again1954/" data-ss-ss-type="share" rel="nofollow noopener"> <span><svg class="ss-svg-icon" aria-hidden="true" role="img" focusable="false" width="28" height="32" viewBox="0 0 28 32" xmlns="http://www.w3.org/2000/svg"><path d="M0 4v21.806c0 3.512 5.5 3.631 5.5 0v-14.912c0.494-3.306 5.5-3.15 5.5 0.406v10.956c0 3.619 6 3.625 6 0v-7.256c0.331-3.419 5.5-3.281 5.5 0.269v1.487c0 3.744 5.5 3.538 5.5 0v-12.756h-28z"></path></svg></span> <span>Mix</span> </a></div><div class="ss-popup-network ss-popup-envelope"> <a href="#" data-ss-ss-link="mailto:?body=https%3A%2F%2Fwww.geeskaafrika.com%2Fsomaliland-to-join-british-commonwealth-again1954%2F&#038;subject=Somaliland%20to%20Join%20British%20Commonwealth%20Again%3A1954" data-id="envelope" class="ss-envelope-color" data-ss-ss-network-id="envelope" data-ss-ss-post-id="33919" data-ss-ss-location="popup" data-ss-ss-permalink="https://www.geeskaafrika.com/somaliland-to-join-british-commonwealth-again1954/" data-ss-ss-type="share" rel="nofollow noopener"> <span><svg class="ss-svg-icon" aria-hidden="true" role="img" focusable="false" width="32" height="32" viewBox="0 0 32 32" xmlns="http://www.w3.org/2000/svg"><path d="M32 12.964v14.179c0 1.571-1.286 2.857-2.857 2.857h-26.286c-1.571 0-2.857-1.286-2.857-2.857v-14.179c0.536 0.589 1.143 1.107 1.804 1.554 2.964 2.018 5.964 4.036 8.875 6.161 1.5 1.107 3.357 2.464 5.304 2.464h0.036c1.946 0 3.804-1.357 5.304-2.464 2.911-2.107 5.911-4.143 8.893-6.161 0.643-0.446 1.25-0.964 1.786-1.554zM32 7.714c0 2-1.482 3.804-3.054 4.893-2.786 1.929-5.589 3.857-8.357 5.804-1.161 0.804-3.125 2.446-4.571 2.446h-0.036c-1.446 0-3.411-1.643-4.571-2.446-2.768-1.946-5.571-3.875-8.339-5.804-1.268-0.857-3.071-2.875-3.071-4.5 0-1.75 0.946-3.25 2.857-3.25h26.286c1.554 0 2.857 1.286 2.857 2.857z"></path></svg></span> <span>Email</span> </a></div><div class="ss-popup-network ss-popup-print"> <a href="#" data-ss-ss-link="#" data-id="print" class="ss-print-color" data-ss-ss-network-id="print" data-ss-ss-post-id="33919" data-ss-ss-location="popup" data-ss-ss-permalink="https://www.geeskaafrika.com/somaliland-to-join-british-commonwealth-again1954/" data-ss-ss-type="share" rel="nofollow noopener"> <span><svg class="ss-svg-icon" aria-hidden="true" role="img" focusable="false" width="30" height="32" viewBox="0 0 30 32" xmlns="http://www.w3.org/2000/svg"><path d="M6.857 27.714h16v-4.571h-16v4.571zM6.857 16.286h16v-6.857h-2.857c-0.946 0-1.714-0.768-1.714-1.714v-2.857h-11.429v11.429zM27.429 17.429c0-0.625-0.518-1.143-1.143-1.143s-1.143 0.518-1.143 1.143 0.518 1.143 1.143 1.143 1.143-0.518 1.143-1.143zM29.714 17.429v7.429c0 0.304-0.268 0.571-0.571 0.571h-4v2.857c0 0.946-0.768 1.714-1.714 1.714h-17.143c-0.946 0-1.714-0.768-1.714-1.714v-2.857h-4c-0.304 0-0.571-0.268-0.571-0.571v-7.429c0-1.875 1.554-3.429 3.429-3.429h1.143v-9.714c0-0.946 0.768-1.714 1.714-1.714h12c0.946 0 2.25 0.536 2.929 1.214l2.714 2.714c0.679 0.679 1.214 1.982 1.214 2.929v4.571h1.143c1.875 0 3.429 1.554 3.429 3.429z"></path></svg></span> <span>Print</span> </a></div><div class="ss-popup-network ss-popup-copy"> <a href="#" data-ss-ss-link="https://www.geeskaafrika.com/somaliland-to-join-british-commonwealth-again1954/" data-id="copy" class="ss-copy-color" data-ss-ss-network-id="copy" data-ss-ss-post-id="33919" data-ss-ss-location="popup" data-ss-ss-permalink="https://www.geeskaafrika.com/somaliland-to-join-british-commonwealth-again1954/" data-ss-ss-type="share" rel="nofollow noopener"> <span><svg class="ss-svg-icon" aria-hidden="true" role="img" focusable="false" width="32" height="32" viewBox="0 0 32 32" xmlns="http://www.w3.org/2000/svg"><path d="M25.313 28v-18.688h-14.625v18.688h14.625zM25.313 6.688c1.438 0 2.688 1.188 2.688 2.625v18.688c0 1.438-1.25 2.688-2.688 2.688h-14.625c-1.438 0-2.688-1.25-2.688-2.688v-18.688c0-1.438 1.25-2.625 2.688-2.625h14.625zM21.313 1.313v2.688h-16v18.688h-2.625v-18.688c0-1.438 1.188-2.688 2.625-2.688h16z"></path></svg></span> <span>Copy Link</span> </a></div></div><div class="ss-powered-by">Powered by <a href="https://socialsnap.com/?utm_source=WordPress&amp;utm_medium=link&amp;utm_campaign=inthewild" target="_blank" rel="nofollow noopener"><svg class="ss-svg-icon" aria-hidden="true" role="img" focusable="false" width="30" height="32" viewBox="0 0 30 32" xmlns="http://www.w3.org/2000/svg"><path d="M22.293 0.146l7.602 4.172c0.386 0.201 0.386 0.541 0 0.757l-16.688 9.147c-1.684 0.943-2.241 2.271-1.669 3.461 0 0.093 0 0.201-0.201 0.263-0.207 0.088-0.441 0.088-0.649 0l-10.399-5.702c-0.386-0.201-0.386-0.541 0-0.757l20.628-11.311c0.428-0.225 0.937-0.236 1.375-0.031zM7.892 31.854l-7.602-4.172c-0.386-0.201-0.386-0.541 0-0.757l16.688-9.147c1.684-0.943 2.241-2.271 1.669-3.461 0-0.093 0-0.201 0.201-0.263 0.207-0.088 0.442-0.088 0.649 0l10.399 5.702c0.386 0.201 0.386 0.541 0 0.757l-20.628 11.311c-0.428 0.225-0.937 0.237-1.375 0.031z"></path></svg>Social Snap</a></div></div></div></div><div id="ss-copy-popup" class="ss-popup-overlay"><div class="ss-popup"><div class="ss-popup-heading"> <span>Copy link</span> <a href="#" class="ss-close-modal" rel="nofollow noopener"> <svg class="ss-svg-icon" aria-hidden="true" role="img" focusable="false" width="32" height="32" viewBox="0 0 32 32" xmlns="http://www.w3.org/2000/svg"><path d="M17.883 16.667l7.058-7.058c0.517-0.517 0.517-1.367 0-1.883s-1.367-0.517-1.883 0l-7.058 7.058-7.058-7.058c-0.517-0.517-1.367-0.517-1.883 0s-0.517 1.367 0 1.883l7.058 7.058-7.058 7.058c-0.517 0.517-0.517 1.367 0 1.883 0.258 0.258 0.6 0.392 0.942 0.392s0.683-0.133 0.942-0.392l7.058-7.058 7.058 7.058c0.258 0.258 0.6 0.392 0.942 0.392s0.683-0.133 0.942-0.392c0.517-0.517 0.517-1.367 0-1.883l-7.058-7.058z"></path></svg> </a></div><div class="ss-popup-content"><div class="ss-copy-action"> <input type="text" readonly="readonly" value="https://www.geeskaafrika.com/somaliland-to-join-british-commonwealth-again1954/" class="ss-copy-action-field" aria-label="Copy" /> <a href="#" class="ss-button" rel="nofollow noopener">Copy<span class="ss-share-network-tooltip">Copied</span></a> <svg class="ss-svg-icon" aria-hidden="true" role="img" focusable="false" width="32" height="32" viewBox="0 0 32 32" xmlns="http://www.w3.org/2000/svg"><path d="M25.313 28v-18.688h-14.625v18.688h14.625zM25.313 6.688c1.438 0 2.688 1.188 2.688 2.625v18.688c0 1.438-1.25 2.688-2.688 2.688h-14.625c-1.438 0-2.688-1.25-2.688-2.688v-18.688c0-1.438 1.25-2.625 2.688-2.625h14.625zM21.313 1.313v2.688h-16v18.688h-2.625v-18.688c0-1.438 1.188-2.688 2.625-2.688h16z"></path></svg></div><div class="ss-powered-by">Powered by <a href="https://socialsnap.com/?utm_source=WordPress&amp;utm_medium=link&amp;utm_campaign=inthewild" target="_blank" rel="nofollow noopener"><svg class="ss-svg-icon" aria-hidden="true" role="img" focusable="false" width="30" height="32" viewBox="0 0 30 32" xmlns="http://www.w3.org/2000/svg"><path d="M22.293 0.146l7.602 4.172c0.386 0.201 0.386 0.541 0 0.757l-16.688 9.147c-1.684 0.943-2.241 2.271-1.669 3.461 0 0.093 0 0.201-0.201 0.263-0.207 0.088-0.441 0.088-0.649 0l-10.399-5.702c-0.386-0.201-0.386-0.541 0-0.757l20.628-11.311c0.428-0.225 0.937-0.236 1.375-0.031zM7.892 31.854l-7.602-4.172c-0.386-0.201-0.386-0.541 0-0.757l16.688-9.147c1.684-0.943 2.241-2.271 1.669-3.461 0-0.093 0-0.201 0.201-0.263 0.207-0.088 0.442-0.088 0.649 0l10.399 5.702c0.386 0.201 0.386 0.541 0 0.757l-20.628 11.311c-0.428 0.225-0.937 0.237-1.375 0.031z"></path></svg>Social Snap</a></div></div></div></div>  <script type="text/javascript">var SocialSnapURL 				= window.location.href;
var SocialSnapShareCacheExpired = 1;
var SocialSnapShareNetworks     = ["facebook","twitter","linkedin","envelope","copy","mix","print"];
if ( -1 !== SocialSnapURL.indexOf('ss_cache_refresh') ) {
SocialSnapShareCacheExpired = true;
} else {
var SocialSnapServerTimestamp 	= 1642443666;
var SocialSnapBrowserTimestamp 	= Date.now();
if ( ! SocialSnapBrowserTimestamp ) {
SocialSnapBrowserTimestamp = new Date().getTime();
}
SocialSnapBrowserTimestamp = Math.floor( SocialSnapBrowserTimestamp / 1000 );
SocialSnapShareCacheExpired = SocialSnapShareCacheExpired && ( SocialSnapBrowserTimestamp - SocialSnapServerTimestamp < 60 );
}</script>  
<script>(function(){
var html_jquery_obj = jQuery('html');
if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {
var path = 'https://www.geeskaafrika.com/wp-content/themes/Newspaper/style.css';
jQuery.get(path, function(data) {
var str_split_separator = '#td_css_split_separator';
var arr_splits = data.split(str_split_separator);
var arr_length = arr_splits.length;
if (arr_length > 1) {
var dir_path = 'https://www.geeskaafrika.com/wp-content/themes/Newspaper';
var splited_css = '';
for (var i = 0; i < arr_length; i++) {
if (i > 0) {
arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
}
//jQuery('head').append('<style>' + arr_splits[i] + '</style>');
var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
});
splited_css += "<style>" + formated_str + "</style>";
}
var td_theme_css = jQuery('link#td-theme-css');
if (td_theme_css.length) {
td_theme_css.after(splited_css);
}
}
});
}
})();</script> <div id="tdw-css-writer" style="display: none" class="tdw-drag-dialog tdc-window-sidebar"><header> <a title="Editor" class="tdw-tab tdc-tab-active" href="#" data-tab-content="tdw-tab-editor">Edit with Live CSS</a><div class="tdw-less-info" title="This will be red when errors are detected in your CSS and LESS"></div></header><div class="tdw-content"><div class="tdw-tabs-content tdw-tab-editor tdc-tab-content-active"> <script>(function(jQuery, undefined) {
jQuery(window).ready(function() {
if ( 'undefined' !== typeof tdcAdminIFrameUI ) {
var $liveIframe  = tdcAdminIFrameUI.getLiveIframe();
if ( $liveIframe.length ) {
$liveIframe.load(function() {
$liveIframe.contents().find( 'body').append( '<textarea class="tdw-css-writer-editor" style="display: none"></textarea>' );
});
}
}
});
})(jQuery);</script> <textarea class="tdw-css-writer-editor td_live_css_uid_1_61e5b3923ef42"></textarea><div id="td_live_css_uid_1_61e5b3923ef42" class="td-code-editor"></div> <script>jQuery(window).load(function (){
if ( 'undefined' !== typeof tdLiveCssInject ) {
tdLiveCssInject.init();
var editor_textarea = jQuery('.td_live_css_uid_1_61e5b3923ef42');
var languageTools = ace.require("ace/ext/language_tools");
var tdcCompleter = {
getCompletions: function (editor, session, pos, prefix, callback) {
if (prefix.length === 0) {
callback(null, []);
return
}
if ('undefined' !== typeof tdcAdminIFrameUI) {
var data = {
error: undefined,
getShortcode: ''
};
tdcIFrameData.getShortcodeFromData(data);
if (!_.isUndefined(data.error)) {
tdcDebug.log(data.error);
}
if (!_.isUndefined(data.getShortcode)) {
var regex = /el_class=\"([A-Za-z0-9_-]*\s*)+\"/g,
results = data.getShortcode.match(regex);
var elClasses = {};
for (var i = 0; i < results.length; i++) {
var currentClasses = results[i]
.replace('el_class="', '')
.replace('"', '')
.split(' ');
for (var j = 0; j < currentClasses.length; j++) {
if (_.isUndefined(elClasses[currentClasses[j]])) {
elClasses[currentClasses[j]] = '';
}
}
}
var arrElClasses = [];
for (var prop in elClasses) {
arrElClasses.push(prop);
}
callback(null, arrElClasses.map(function (item) {
return {
name: item,
value: item,
meta: 'in_page'
}
}));
}
}
}
};
languageTools.addCompleter(tdcCompleter);
window.editor = ace.edit("td_live_css_uid_1_61e5b3923ef42");
// 'change' handler is written as function because it's called by tdc_on_add_css_live_components (of wp_footer hook)
// We did it to reattach the existing compiled css to the new content received from server.
window.editorChangeHandler = function () {
//tdwState.lessWasEdited = true;
window.onbeforeunload = function () {
if (tdwState.lessWasEdited) {
return "You have attempted to leave this page. Are you sure?";
}
return false;
};
var editorValue = editor.getSession().getValue();
editor_textarea.val(editorValue);
if ('undefined' !== typeof tdcAdminIFrameUI) {
tdcAdminIFrameUI.getLiveIframe().contents().find('.tdw-css-writer-editor:first').val(editorValue);
// Mark the content as modified
// This is important for showing info when composer closes
tdcMain.setContentModified();
}
tdLiveCssInject.less();
};
editor.getSession().setValue(editor_textarea.val());
editor.getSession().on('change', editorChangeHandler);
editor.setTheme("ace/theme/textmate");
editor.setShowPrintMargin(false);
editor.getSession().setMode("ace/mode/less");
editor.setOptions({
enableBasicAutocompletion: true,
enableSnippets: true,
enableLiveAutocompletion: false
});
}
});</script> </div></div><footer> <a href="#" class="tdw-save-css">Save</a><div class="tdw-more-info-text">Write CSS OR LESS and hit save. CTRL + SPACE for auto-complete.</div><div class="tdw-resize"></div></footer></div> <script defer src="https://www.geeskaafrika.com/wp-content/cache/autoptimize/js/autoptimize_ff4bc1da608e25831b5ced07e51e910f.js"></script></body></html><!-- WP Fastest Cache file was created in 0.30573797225952 seconds, on 17-01-22 13:21:06 -->